Last Comment Bug 750183 - Don't nuke chrome->chrome cross-compartment wrappers
: Don't nuke chrome->chrome cross-compartment wrappers
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks: cpg
  Show dependency treegraph
 
Reported: 2012-04-30 01:50 PDT by Bobby Holley (PTO through June 13)
Modified: 2012-05-04 03:17 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Don't nuke chrome->chrome cross-compartment wrappers. (1.06 KB, patch)
2012-04-30 08:00 PDT, Bobby Holley (PTO through June 13)
bobbyholley: review+
Details | Diff | Review

Description Bobby Holley (PTO through June 13) 2012-04-30 01:50:20 PDT
In bug 695480, we added code to nuke cross-compartment wrappers to dying scopes. This messed up compartment-per-global, but hopefully only because we now have many system compartments (instead of only one). Bug 695480 was mostly about killing chrome->content memory leaks, so we can hopefully just bail on the chrome->chrome wrapper case.

Kyle wrote the patch, which I'll attach and push to try momentarily.
Comment 1 Bobby Holley (PTO through June 13) 2012-04-30 02:25:45 PDT
Pushed to try with c-p-g: https://tbpl.mozilla.org/?tree=Try&rev=e0ff4a8c8098
Comment 2 Boris Zbarsky [:bz] 2012-04-30 06:17:50 PDT
We should consider bailing on the content-to-content case too, if we don't already, since that one would affect web-visible behavior.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-04-30 06:20:56 PDT
We bail in the content->* case already.
Comment 4 Bobby Holley (PTO through June 13) 2012-04-30 08:00:55 PDT
Created attachment 619563 [details] [diff] [review]
Don't nuke chrome->chrome cross-compartment wrappers.
Comment 5 Bobby Holley (PTO through June 13) 2012-05-03 00:13:34 PDT
Pushed to m-i:
http://hg.mozilla.org/integration/mozilla-inbound/rev/a25ce1b3edf8
Comment 6 Ed Morley [:emorley] 2012-05-04 03:17:09 PDT
https://hg.mozilla.org/mozilla-central/rev/a25ce1b3edf8

Note You need to log in before you can comment on or make changes to this bug.