Last Comment Bug 750193 - get rid useless DEBUG_A11Y code
: get rid useless DEBUG_A11Y code
Status: RESOLVED FIXED
[good first bug][mentor=eitan@monoton...
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Max Li [:maxli]
:
:
Mentors:
Depends on:
Blocks: cleana11y
  Show dependency treegraph
 
Reported: 2012-04-30 02:40 PDT by alexander :surkov
Modified: 2012-05-04 02:27 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.81 KB, patch)
2012-04-30 16:52 PDT, Max Li [:maxli]
eitan: review+
Details | Diff | Splinter Review

Comment 1 alexander :surkov 2012-04-30 02:48:11 PDT
(In reply to alexander :surkov from comment #0)
> 1)
> http://mxr.mozilla.org/mozilla-central/source/accessible/src/html/
> nsHTMLTableAccessible.cpp#1300 since the code is under SHOW_LAYOUT_HEURISTIC
> ifdef

remove ifdefs

> 2)
> http://mxr.mozilla.org/mozilla-central/source/accessible/src/base/
> nsAccessNode.cpp#95 - just handing piece of code
> 3)
> http://mxr.mozilla.org/mozilla-central/source/accessible/src/base/
> nsDocAccessible.cpp#1770 - you can do that by DOMi tool

remove entire blocks
Comment 2 Max Li [:maxli] 2012-04-30 16:52:22 PDT
Created attachment 619765 [details] [diff] [review]
Patch v1
Comment 3 Eitan Isaacson [:eeejay] 2012-05-01 12:05:57 PDT
Comment on attachment 619765 [details] [diff] [review]
Patch v1

Review of attachment 619765 [details] [diff] [review]:
-----------------------------------------------------------------

This is good. Thanks!

I am assuming that this bug is only for those 3 files and not for getting rid of DEBUG_A11Y over all. If it is, then another bug should be opened.
Comment 5 Ed Morley [:emorley] 2012-05-04 02:27:05 PDT
https://hg.mozilla.org/mozilla-central/rev/24f9b828d28a

Note You need to log in before you can comment on or make changes to this bug.