Accelerator for Mark Thread as Read

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: Håkan Waara, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I would like an accelerator for the Mark Thread as Read menuitem...

Updated

18 years ago
QA Contact: esther → nbaca

Comment 1

18 years ago
't' actually works but for some reason isn't showing up in the menu anymore.

reassigning to ssu.
Assignee: sspitzer → ssu
Keywords: nsbeta1
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9

Comment 2

18 years ago
I was confused when I wrote the last comment.  't' is for go next unread thread
which also does a mark thread read and it's showing up correctly in the menu item.

removing the nsbeta1+ and mozilla0.9.  It might still be worthwhile to have one
but I was concerned that we were implementing it and not showing it in the menu
item which turns out not to be the case.
Keywords: nsbeta1
Whiteboard: [nsbeta1+]
Target Milestone: mozilla0.9 → ---
(Reporter)

Comment 3

17 years ago
*** Bug 96421 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

17 years ago
Looking at the mail and newsgroups spec, there isn't an accelerator for
'Mark'|'Thread As Read' yet.  I'll add the accelerator when Jennifer decides on
what it should be in the spec. 

Jennifer, shall I create a bug for the request of an accelerator for the
mentioned menuitem command?
Status: NEW → ASSIGNED

Updated

17 years ago
QA Contact: nbaca → olgam

Comment 5

17 years ago
hwaara, take a look at aaron's accelerator spec:
http://www.mozilla.org/projects/ui/accessibility/mozkeyplan.html

If there is a letter you like that is available and approved by aaron, let 
me know and i'll add it to the menu spec.

Comment 6

17 years ago
The letter "R" seems unused, and while not ideal, seems OK for "Mark Thread as 
Read".

As incentive, attaching a patch that implements it :)

Comment 7

17 years ago
Created attachment 68700 [details] [diff] [review]
Proposed patch

Implements "R" as the accelerator.
(Reporter)

Comment 8

17 years ago
Ok, so this would mean you marked a thread read when you press "r", right?
Jglick, can you approve this too?

Comment 9

17 years ago
Aaron should approve this since he's our accessibility king. If he's ok with it, 
so am I. 

Comment 10

17 years ago
The patch is proposed only on 02-08-2002 but I see it is implemented even on
04-04-2002 builds as well in today's build. Messages|Mark| - right? I make View:
Threaded, then check in Newsgroups also - works:
As 'R'ead
'T'hread As Read
'A'll Read


Comment 11

17 years ago
I officially approve :) 
olga: re comment 10:  This is not the shortcut key for the menu, but a global 
accelerator.  Thus, you can already select "Mark as Read" from the menu 
using "R", or when no menu is selected via "M" (as reflected in the menu text 
itself).

Mark Thread As Read did have a menu shortcut ("T") but had no global 
accelerator.  My patch implements "R".

I will take jglick and aaron's comments as r= - can anyone offer an sr=?
(Assignee)

Comment 13

17 years ago
Comment on attachment 68700 [details] [diff] [review]
Proposed patch

r=ssu

I'll go look for the sr= and check the patch in for you too.
Attachment #68700 - Flags: review+

Comment 14

17 years ago
Comment on attachment 68700 [details] [diff] [review]
Proposed patch

sr=mscott
Attachment #68700 - Flags: superreview+
(Assignee)

Comment 15

17 years ago
patch checked in.  marking bug fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
Verified on Win2K and Linux.
Status: RESOLVED → VERIFIED
I missed the "Mark" menu dropdown.  I added bug 125986 for this.

Also, this bug references 
http://www.mozilla.org/projects/ui/accessibility/mozkeyplan.html - it too 
should be updated to reflect the new "R" accelerator.  I can't see the file in 
the CVS tree though.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.