crash [@ JSC::Yarr::digitsCreate ]

RESOLVED DUPLICATE of bug 990787

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 990787
6 years ago
4 years ago

People

(Reporter: xti, Unassigned)

Tracking

({crash})

14 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-c6010b45-1b5f-442e-927a-3515c2120430 .
============================================================= 

Frame 	Module 	Signature 	Source
0 	libxul.so 	JSC::Yarr::digitsCreate 	Utility.h:597
1 	libxul.so 	JSC::Yarr::YarrPatternConstructor::atomBuiltInCharacterClass 	js/src/yarr/YarrPattern.h:380
2 	libxul.so 	JSC::Yarr::Parser<JSC::Yarr::YarrPatternConstructor>::parseTokens 	js/src/yarr/YarrParser.h:271
3 	libxul.so 	JSC::Yarr::YarrPattern::YarrPattern 	js/src/yarr/YarrParser.h:668
4 	libxul.so 	js::detail::RegExpCode::compile 	js/src/vm/RegExpObject.cpp:246
5 	libxul.so 	js::RegExpObject::createShared 	js/src/vm/RegExpObject.cpp:534
6 	libxul.so 	js::CloneRegExpObject 	js/src/vm/RegExpObject-inl.h:82
7 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2927
8 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:475
9 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:535
10 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5416
11 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1509
12 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:617
13 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:138
14 	libxul.so 	libxul.so@0xa1435f 	
15 	libxul.so 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:818
16 	libxul.so 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:875
17 	libxul.so 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventListenerManager.h:169
18 	libxul.so 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:349
19 	libxul.so 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:684
20 	libxul.so 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:747
21 	libxul.so 	nsDOMEventTargetHelper::DispatchDOMEvent 	content/events/src/nsDOMEventTargetHelper.cpp:299
22 	libxul.so 	nsXMLHttpRequest::DispatchDOMEvent 	content/base/src/nsXMLHttpRequest.h:106
23 	libxul.so 	nsXMLHttpRequest::DispatchProgressEvent 	content/base/src/nsXMLHttpRequest.cpp:1708
24 	libxul.so 	nsXMLHttpRequest::DispatchProgressEvent 	content/base/src/nsXMLHttpRequest.h:505
25 	libxul.so 	nsXMLHttpRequest::ChangeStateToDone 	content/base/src/nsXMLHttpRequest.cpp:2493
26 	libxul.so 	nsXMLHttpRequest::OnStopRequest 	content/base/src/nsXMLHttpRequest.cpp:2448
27 	libxul.so 	nsHTTPCompressConv::OnStopRequest 	netwerk/streamconv/converters/nsHTTPCompressConv.cpp:127
28 	libxul.so 	nsHttpChannel::OnStopRequest 	netwerk/protocol/http/nsHttpChannel.cpp:4495
29 	libxul.so 	nsInputStreamPump::OnStateStop 	netwerk/base/src/nsInputStreamPump.cpp:587
30 	libxul.so 	nsInputStreamPump::OnInputStreamReady 	netwerk/base/src/nsInputStreamPump.cpp:405
31 	libxul.so 	nsInputStreamReadyEvent::Run 	xpcom/io/nsStreamUtils.cpp:114
32 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:656
33 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
34 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
35 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
36 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
37 	libxul.so 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:189
38 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:295
39 	libxul.so 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3780
40 	libxul.so 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3857
41 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3933
42 	libxul.so 	GeckoStart 	toolkit/xre/nsAndroidStartup.cpp:109
43 	libmozglue.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	mozglue/android/APKOpen.cpp:996
44 	libdvm.so 	dvmPlatformInvoke 	
45 	libdvm.so 	dvmCallJNIMethod_general 	
46 	libdvm.so 	dvmResolveNativeMethod 	
47 	libdvm.so 	dvmAsmSisterStart 	
48 	libdvm.so 	dvmMterpStd 	
49 	libdvm.so 	dvmInterpret 	
50 	libdvm.so 	dvmCallMethodV 	
51 	libdvm.so 	dvmCallMethod 	
52 	libdvm.so 	dvmDetachCurrentThread 	
53 	libc.so 	__thread_entry 	
54 	libc.so 	pthread_create 	

This crash occurred while I was trying to reproduce bug 750272 on the latest Aurora build.

--
Firefox 14.0a2 (2012-04-30)
Device: Samsung Captivate
OS: Android 2.2

Updated

6 years ago
Assignee: nobody → general
Component: IME → JavaScript Engine
Product: Fennec Native → Core
QA Contact: ime → general
Whiteboard: [native-crash]
Version: Firefox 14 → 14 Branch

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 990787
You need to log in before you can comment on or make changes to this bug.