Last Comment Bug 750334 - rotating image appears too big during transition, then snaps to correct size
: rotating image appears too big during transition, then snaps to correct size
Status: VERIFIED FIXED
: mobile
Product: Core
Classification: Components
Component: Layout (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Matt Woodrow (:mattwoodrow)
:
: Jet Villegas (:jet)
Mentors:
http://rugby.mit.edu
: 749420 752099 753406 753434 754982 756467 (view as bug list)
Depends on: 767292
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 10:17 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-06-22 01:34 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified
+


Attachments
screenshot of layed out too big (194.93 KB, image/png)
2012-04-30 10:17 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details
screenshot from nytimes front page (455.07 KB, image/png)
2012-05-08 09:41 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details
Always apply the scale to image layers (1.82 KB, patch)
2012-05-14 15:32 PDT, Matt Woodrow (:mattwoodrow)
roc: review+
joe: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2012-04-30 10:17:56 PDT
Created attachment 619608 [details]
screenshot of layed out too big

The site has a section at the top that rotates between 3 photos with a fade transition. During that transition, the images are layed out much too big. Once the transition is complete, they snap to the correct size.
Comment 1 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-04-30 22:44:27 PDT
So this is Fennec, not Mac desktop?
Comment 2 Timothy Nikkel (:tnikkel) 2012-04-30 23:01:22 PDT
It seems so.

It is some problem with how we configure image layers when we optimize thebes layers into image layers. All it takes is an image that has its opacity animated to show the problem.
Comment 3 Chris Lord [:cwiiis] 2012-05-03 08:53:53 PDT
Maybe related to bug 741173? Though perhaps not, going on Joe's latest comment on that bug.
Comment 4 Brad Lassey [:blassey] (use needinfo?) 2012-05-03 12:17:37 PDT
Ali, can you dupe this if it is a dupe?
Comment 5 Ali Juma [:ajuma] 2012-05-03 13:05:03 PDT
(In reply to Chris Lord [:cwiiis] from comment #3)
> Maybe related to bug 741173? Though perhaps not, going on Joe's latest
> comment on that bug.

The patch for Bug 728026 fixes Bug 741173 but doesn't fix this bug, so this seems to be a different issue.
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-05-07 12:13:55 PDT
*** Bug 752099 has been marked as a duplicate of this bug. ***
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-05-08 09:41:51 PDT
Created attachment 622012 [details]
screenshot from nytimes front page

saw this on the nytimes this morning
Comment 8 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-09 14:16:34 PDT
*** Bug 753434 has been marked as a duplicate of this bug. ***
Comment 9 Ali Juma [:ajuma] 2012-05-11 13:56:59 PDT
To help debug this, I've made a minimal testcase at http://people.mozilla.org/~ajuma/opacity

As noted by tn in Comment 2, all that's needed is an image that has its opacity animated.
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2012-05-13 17:53:16 PDT
(In reply to Robert O'Callahan (:roc) (Mozilla Corporation) from comment #1)
> So this is Fennec, not Mac desktop?

Yup, sorry. This is Fennec.
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2012-05-13 17:54:14 PDT
*** Bug 753406 has been marked as a duplicate of this bug. ***
Comment 12 Ali Juma [:ajuma] 2012-05-14 08:14:52 PDT
(In reply to Timothy Nikkel (:tn) from comment #2)
> It is some problem with how we configure image layers when we optimize
> thebes layers into image layers. 

Indeed; turning off the thebes layer to image layer optimization prevents the problem.
Comment 13 Matt Woodrow (:mattwoodrow) 2012-05-14 15:32:45 PDT
Created attachment 623848 [details] [diff] [review]
Always apply the scale to image layers

I think this should fix the problem, can someone try it please :)
Comment 14 Timothy Nikkel (:tnikkel) 2012-05-14 22:47:18 PDT
Yep, that patch fixes it.
Comment 15 Brad Lassey [:blassey] (use needinfo?) 2012-05-15 03:19:27 PDT
landed on inbound https://hg.mozilla.org/integration/mozilla-inbound/rev/dd3c873674fc
Comment 16 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-15 06:29:43 PDT
*** Bug 754982 has been marked as a duplicate of this bug. ***
Comment 17 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-15 07:02:29 PDT
Is there a similar code path that might apply to frames of a video (bug 754434)? I can reproduce that bug even with the patch from this build.
Comment 18 Ed Morley [:emorley] 2012-05-16 03:56:42 PDT
https://hg.mozilla.org/mozilla-central/rev/dd3c873674fc
Comment 19 Adrian Tamas (:AdrianT) 2012-05-18 04:37:33 PDT
Issue is still reproducible on Aurora 14.0a2 2012-05-17 using http://people.mozilla.org/~ajuma/opacity.

Verified fix on:
Build: Nightly 15.0a1 2012-05-17
Device: HTC Desire Z
OS: Android 2.3.3
Comment 20 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-22 14:21:18 PDT
Should this be uplifted?
Comment 21 Brad Lassey [:blassey] (use needinfo?) 2012-05-22 15:06:29 PDT
(In reply to Kartikaya Gupta (:kats) from comment #20)
> Should this be uplifted?

Yes. Matt, can you please request approval?
Comment 22 Matt Woodrow (:mattwoodrow) 2012-05-22 15:53:53 PDT
Comment on attachment 623848 [details] [diff] [review]
Always apply the scale to image layers

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 695275
User impact if declined: Misplaced images
Testing completed (on m-c, etc.): Landed on m-c for almost a week, verified as fixing the issue.
Risk to taking this patch (and alternatives if risky): Very low risk, just changes the scaling applied to images.
String or UUID changes made by this patch: None

Do we want approval for beta too?
Comment 23 Kartikaya Gupta (email:kats@mozilla.com) 2012-05-23 06:48:36 PDT
*** Bug 756467 has been marked as a duplicate of this bug. ***
Comment 24 Joe Drew (not getting mail) 2012-05-25 12:08:31 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/4f318c1fea77
Comment 25 Joe Drew (not getting mail) 2012-05-28 11:49:47 PDT
*** Bug 749420 has been marked as a duplicate of this bug. ***
Comment 26 Catalin Suciu [:csuciu] 2012-05-31 04:59:04 PDT
Verified fixed on:
Nightly 15.0a1 (2012-05-31)
Aurora 14.0a2 (2012-05-30)
Beta 14.0b4 

Samsung Galaxy SII (2.3.4)
Comment 27 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-04 17:59:49 PDT
(In reply to Matt Woodrow (:mattwoodrow) from comment #22)
> Do we want approval for beta too?

Yes, we needed to get this into beta :-( to fix bug 735373.
Comment 28 Robert O'Callahan (:roc) (email my personal email if necessary) 2012-06-04 18:00:18 PDT
Comment on attachment 623848 [details] [diff] [review]
Always apply the scale to image layers

Review of attachment 623848 [details] [diff] [review]:
-----------------------------------------------------------------

Simple safe patch that fixes regression in bug 735373
Comment 29 Johnathan Nightingale [:johnath] 2012-06-05 11:52:14 PDT
Comment on attachment 623848 [details] [diff] [review]
Always apply the scale to image layers

Clearing the approval nom - this landed on aurora before migration, and should be uplifted to beta automatically

Note You need to log in before you can comment on or make changes to this bug.