Last Comment Bug 750387 - consider blocklisting Adobe Reader (10.1.3)
: consider blocklisting Adobe Reader (10.1.3)
Status: VERIFIED FIXED
:
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jorge Villalobos [:jorgev]
Mentors:
Depends on: 747073 750330
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-30 11:53 PDT by Alex Keybl [:akeybl]
Modified: 2016-03-07 15:30 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Keybl [:akeybl] 2012-04-30 11:53:18 PDT
We should consider blocklisting Adobe Reader (10.1.3) given bug 747073, which causes Adobe reader to malfunction on 64 bit versions of Firefox on OS X. If it's possible to blocklist for 64-bit versions of OS X Firefox specifically, we should do that.
Comment 1 Alex Keybl [:akeybl] 2012-04-30 11:53:41 PDT
We should start by getting this staged, so that QA can report back on the user experience after blocking.
Comment 2 Jorge Villalobos [:jorgev] 2012-04-30 14:22:33 PDT
It's up at https://addons-dev.allizom.org/en-US/firefox/blocked/p86, but it looks like bug 750330 is also causing problems for this entry.

The current block is limited to Mac OS X, and blocks all versions of the Adobe Reader plugin up to 10.1.3, for all versions of Firefox. It's a softblock, so users can bypass it. We can't limit the block to 64 bit versions, though.
Comment 3 Steven Michaud [:smichaud] (Retired) 2012-04-30 14:28:45 PDT
> https://addons-dev.allizom.org/en-US/firefox/blocked/p86

> Why was it blocked?
> The Adobe Acrobat plugin is causing a significant amount of Firefox bugs and crashes in modern (64 bit) versions of Mac OS X.

The answer to "why was it blocked" isn't accurate.

It should be something like:

The Adobe Acrobat plugin doesn't work in default (64-bit) mode, and causes a significant number of crashes in 32-bit mode.
Comment 4 Jorge Villalobos [:jorgev] 2012-05-01 14:08:58 PDT
The block is now staged and I can confirm it's working correctly and ready for testing.
Comment 5 Mihaela Velimiroviciu (:mihaelav) 2012-05-02 05:18:03 PDT
I've tested around this change on Mac OS X and these are the results I found. Notice that the block doesn't seem to work on Firefox 12 release 32 bit on Mac OSX 10.7 and there are some interoperability issues with other PDF viewer plugin (PDF Browser plug-in)

-----------------------------------------------------------------------------
Environment 1:
OS: Mac OSX 10.6.8
Firefox builds: 12.0 release and 13.0beta1, both 32 and 64 bits
Adobe Acrobat version: 10.1.3
Test PDF: http://www.education.gov.yk.ca/pdf/pdf-test.pdf
Others: PDF Browser plugin 2.4.2 was also installed

Adobe Acrobat NPAPI Plugin is listed as enabled in Addons Manager

Case 1: Adobe Acrobat enabled, PDF Browser enabled - when trying to open the PDF only a blank page is displayed
Case 2: Adobe Acrobat enabled, PDF Browser disabled - open PDF dialog is displayed (with "Preview" as default)
Case 3: Adobe Acrobat disabled, PDF Browser enabled - PDF opens with PDF Browser plug-in

-----------------------------------------------------------------------------
Environment 2:
OS: Mac OSX 10.7.3
Firefox builds: 12.0 release 64bit and 13.0beta1 both 32 and 64bits
Adobe Acrobat version: 10.1.3
Test PDF: http://www.education.gov.yk.ca/pdf/pdf-test.pdf
Others: PDF Browser plugin 2.4.4 was also installed

Adobe Acrobat NPAPI Plugin is listed as enabled in Addons Manager

Case 1: Adobe Acrobat enabled - when trying to open the PDF only a blank page is displayed (no matter the status of PDF Browser: enabled/disabled)
Case 2: Adobe Acrobat disabled - PDF opens with Preview/PDF browser plugin

-----------------------------------------------------------------------------
Environment 3:
OS: Mac OSX 10.7.3
Firefox builds: 12.0 release 32bit
Adobe Acrobat version: 10.1.3
Test PDF: http://www.education.gov.yk.ca/pdf/pdf-test.pdf
Others: PDF Browser plugin 2.4.4 was also installed

Adobe Acrobat NPAPI Plugin is listed as enabled in Addons Manager

Case 1: Adobe Acrobat enabled - PDF is opened with Adobe reader(no matter the status of PDF Browser: enabled/disabled)
Case 2: Adobe Acrobat disabled - PDF opens with Preview/PDF Browser plugin
Comment 6 Alex Keybl [:akeybl] 2012-05-02 10:48:34 PDT
A few questions:

* Was "Adobe Acrobat NPAPI Plugin" ever noted as blocked? Is that what "Adobe Acrobat disabled" means? 
* What's the issue with 10.7.3? It's not clear from the comment. 
* What exactly was the interoperability problem with "PDF Browser plugin"? As long as the user is seeing the PDF somehow when they click a PDF link, I think we're fine.
Comment 7 Mihaela Velimiroviciu (:mihaelav) 2012-05-03 07:36:15 PDT
(In reply to Alex Keybl [:akeybl] from comment #6)
> A few questions:
> 
> * Was "Adobe Acrobat NPAPI Plugin" ever noted as blocked? Is that what
> "Adobe Acrobat disabled" means? 
"Adobe Reader 10.1.3" was downloaded from the adobe website and after installation it appears in Firefox as "Adobe Acrobat NPAPI Plugin 10.1.3". "Disabled" means that plugin was manually disabled in Addons Manager.

> * What's the issue with 10.7.3? It's not clear from the comment. 
On 10.7.3 with Firefox 12 in 32bit mode PDFs were opened using the Adobe plugin (Shouldn't it be blocked and PDFs open with Preview, like in the 64bit mode?)

> * What exactly was the interoperability problem with "PDF Browser plugin"?
> As long as the user is seeing the PDF somehow when they click a PDF link, I
> think we're fine.
IMO the problem is that when both Adobe and PDF Browser plugin are installed (and appear as enabled in Addons Manager), opening a PDF displays a blank page instead of downloading and opening with Preview or with the PDF browser plugin, so the user doesn't see the PDF at all.
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-03 15:17:22 PDT
> 1. Start Firefox 12 with a new profile
> 2. Install Adobe Reader plugin v10.1.3
> 3. Restart Firefox and open http://www.mathstat.uottawa.ca/~rsmith/Zombies.pdf

PDF does not open in App, renders in Firefox as a blank white page

> 4. Set extensions.blocklist.url to use addons-dev-allizom.org and restart Firefox
> 5. Force a blocklist ping

Prompt appears stating Adobe Acrobat NPAPI Plug-in, Version 10.1.3 may be causing problems and asks permission to disable.

> 6. Click restart to accept
> 7. Open the addons manager

Adobe Acrobat NPAPI plugin is disabled in Addons Manager.

> 8. Open http://www.mathstat.uottawa.ca/~rsmith/Zombies.pdf

Firefox prompts to Open With Adobe Reader or Save File.

> 9. Opt to "Open with Adobe Reader"

Opens the PDF in Adobe Reader.

> 10. Opt to "Open with" and change the app to Preview

Opens the PDF with Preview.app

> 11. Opt to "Save File"

File is downloaded and I'm able to open manually with Adobe Reader or Preview.app

Conclusions:
As far as I can tell the block is working. The fact that the PDF is showing blank when rendered in browser with the plugin enabled is concerning but not related to this bug in any way, shape, or form.

NOTE: If I force Firefox to run in 32-bit mode the blocklist does NOT appear to work. Forcing a blocklist ping does not display any dialog asking me to disable Acrobat. I also don't see an entry in my profile's blocklist.xml for "p86" in this scenario.
Comment 9 Steven Michaud [:smichaud] (Retired) 2012-05-03 15:22:39 PDT
> NOTE: If I force Firefox to run in 32-bit mode the blocklist does
> NOT appear to work. Forcing a blocklist ping does not display any
> dialog asking me to disable Acrobat. I also don't see an entry in my
> profile's blocklist.xml for "p86" in this scenario.

So we might be able to blocklist the Adobe Reader 10.1.3 plugin only
in 64-bit mode?

Or is this just a bug?
Comment 10 Alex Keybl [:akeybl] 2012-05-03 15:26:58 PDT
(In reply to Steven Michaud from comment #9)
> So we might be able to blocklist the Adobe Reader 10.1.3 plugin only
> in 64-bit mode?
> 
> Or is this just a bug?

We're in #planning right now attempting to reproduce. If it's a bug in our blocklisting mechanism, we'll file it separately. It wouldn't block pushing the blocklist to production, however.
Comment 11 Alex Keybl [:akeybl] 2012-05-03 15:27:42 PDT
Jorge let us know that if it's not a bug, the block of just the 64-bit version wasn't intentional.
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-03 15:38:57 PDT
Nevermind, I was using the wrong pref when I tested 32-bit.

Using the same steps as comment 8 under 32-bit mode the blocklist disables and asks me to open PDFs in either Adobe Reader, Preview.app, or Save File.

I also checked the case of when a user also has the PDF Browser Plugin installed. If the plugin is enabled with Adobe Reader is blocked, PDFs open in-browser using the PDF Browser plugin. If both are disabled, it asks me to open with Adobe Reader, Preview.app, or save the file.

I don't see any problems with the blocklist and see no reasons it shouldn't be pushed to production.
Comment 13 Alex Keybl [:akeybl] 2012-05-03 15:39:58 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #12)
> I don't see any problems with the blocklist and see no reasons it shouldn't
> be pushed to production.

We'll let Adobe know we're ready.
Comment 14 Alex Keybl [:akeybl] 2012-05-04 11:04:09 PDT
We've coordinated with Adobe - let's move forward with pushing the blocklist to production.
Comment 16 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-04 12:09:39 PDT
Confirmed working on production.

Note You need to log in before you can comment on or make changes to this bug.