In-app purchases don't show up if app isn't listed in history

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: fligtar, Assigned: andy+bugzilla)

Tracking

Details

(Reporter)

Description

7 years ago
STR:
1. Install free game from Account 1
2. Launch app, play game, no problems
3. Make in-app purchase, but log in with Account 2
4. Go to Account 2's History and don't see in-app purchase

In this case, we should probably list the app in Account History with the purchases under it, but we wouldn't display the "purchased" info for the app.

This is a legitimate use case as someone may have an account for only free usage but when they want to buy something they use a parent or other's account.
(Assignee)

Updated

7 years ago
Assignee: nobody → amckay
(Assignee)

Comment 1

7 years ago
Ah inapp show up, but are filtered by installed ids. I don't think that's needed, will remove.
(Assignee)

Comment 2

7 years ago
No that's not it. Can't reproduce. Test added since it's a use case we shouldn't let go without a test.

https://github.com/mozilla/zamboni/commit/28ba64
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.