[in-app] Let us show user-friendly error messages

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: potch)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 619661 [details]
screenshot

Similar to bug 746660

steps to reproduce:
1. Load http://inapp-pay-test.farmdev.com/en-US/
2. Edit the data field for price to blank
3. Click on the call mozmarket.buy()

actual behavior:
The error we show says 'RequestVerificationError' which doesn't tell the end-user a lot. Let us show something more informative and friendly instead.
(Reporter)

Comment 1

7 years ago
One more sample:

This is on using "aud": "marketplac.mozilla.org"

Payment Error : InvalidRequest

Payment JWT aud (audience) must be set to 'marketplace.mozilla.org'; got: u'marketplac.mozilla.org' (app ID=u'ZNKFXKOFY3K9U73E5VHB')
(Assignee)

Comment 2

7 years ago
These are pretty now, but we still need more descriptive messages.

https://github.com/mozilla/zamboni/commit/f546974
Thanks Potch.  What kind of messages did you have in mind?  Generic is probably good for the end user, with substantial logging on our end.
Blocks: 698116
No longer blocks: 735054
Keep in mind that you were running in this in -dev which has debug info turned on. This exception is intended for in-app developers to understand what they did wrong. This kind of message will not be shown in production. A user would see this in production: https://bug752809.bugzilla.mozilla.org/attachment.cgi?id=621885

I'd like to keep descriptive exception messages like this in -dev to make in-app development easier. What should be changed? It currently tells you about a syntax error in the JSON and points to where to fix it.
(Reporter)

Comment 5

7 years ago
I didn't know we had debugging enabled on -dev. Having verbose errors in -dev is definitely useful.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

7 years ago
Blocks: 745006
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.