search folder picker can fire onChooseFolder() twice

RESOLVED DUPLICATE of bug 68174

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 68174
17 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

in our search js, we'll fail because folderURI is "".

gCurrentFolder = RDF.GetResource(folderURI).QueryInterface(nsIMsgFolder);


our template code and oncommand handers for the folder picker are calling
onChooseFolder() twice, the second time event.id is ""

I think we're firing our oncommand handler twice.  the plan is to move it out of
the generated content, right?
I've got a crude patch to fix the problem until the real issue is fixed
Created attachment 30001 [details] [diff] [review]
fix until the real problem is fixed.
my safety checking fix is in.

changing subject.  now this bug can be marked as a duplicate of the bug where
you (or gayatrib?) are going to move the oncommand handler out of the generated
xul.
Summary: can't choose "choose this folder" for searching → search folder picker can fire onChooseFolder() twice

Updated

17 years ago
QA Contact: esther → laurel
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail

Comment 5

10 years ago
spitzer in comment #3:
> ... now this bug can be marked as a duplicate of the bug where
> you (or gayatrib?) are going to move the oncommand handler out of the generated xul.

Seth, I was not able to find the bug in question.
> Seth, I was not able to find the bug in question.

hey wayne, I think I meant bug #68174, but at this point (6+ years later), your guess / bugzilla query is as good as mine.

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 68174

Updated

9 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.