Get rid of OSX-specific compiler warnings and turn on FAIL_ON_WARNINGS

RESOLVED DUPLICATE of bug 745296

Status

()

RESOLVED DUPLICATE of bug 745296
7 years ago
6 years ago

People

(Reporter: jduell, Assigned: valentin)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

OSX has a bunch of non-trivial compiler warnings in streamconv/src/nsAppleFileDecoder.cpp.  We should fix and add FAIL_ON_WARNINGS to streamconv/src/Makefile.in.

/usr/local/bin/ccache /usr/bin/g++-4.2 -arch i386 -o nsAppleFileDecoder.o -c  -fvisibility=hidden -DMOZILLA_INTERNAL_API -D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI -DIMPL_NS_NET -DIMPL_THEBES  -DSTATIC_EXPORTABLE_JS_API -DIMPL_NS_NET  -I/builds/slave/try-osx64/build/netwerk/streamconv/src -I. -I../../../dist/include -I../../../dist/include/nsprpub  -I/builds/slave/try-osx64/build/obj-firefox/i386/dist/include/nspr -I/builds/slave/try-osx64/build/obj-firefox/i386/dist/include/nss      -fPIC  -fno-rtti -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wcast-align -isysroot /Developer/SDKs/MacOSX10.6.sdk -fno-exceptions -fno-strict-aliasing -fno-common -fshort-wchar -ffunction-sections -fdata-sections -pthread -DNO_X11 -pipe  -DNDEBUG -DTRIMMED -g -O3 -fomit-frame-pointer -Werror -Wno-error=uninitialized   -DMOZILLA_CLIENT -include ../../../mozilla-config.h -MD -MF .deps/nsAppleFileDecoder.pp /builds/slave/try-osx64/build/netwerk/streamconv/src/nsAppleFileDecoder.cpp
cc1plus: warnings being treated as errors
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp: In member function 'virtual nsresult nsAppleFileDecoder::Close()':
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:99: warning: 'FSClose' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8345)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:99: warning: 'FSClose' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8345)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:133: warning: 'PBGetCatInfoSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8721)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:133: warning: 'PBGetCatInfoSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8721)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:147: warning: 'PBSetCatInfoSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8751)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:147: warning: 'PBSetCatInfoSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8751)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:158: warning: 'PBHGetVolParmsSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:7631)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:158: warning: 'PBHGetVolParmsSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:7631)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:162: warning: 'PBDTGetPath' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:9683)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:162: warning: 'PBDTGetPath' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:9683)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:168: warning: 'PBDTSetCommentSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:9879)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:168: warning: 'PBDTSetCommentSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:9879)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:169: warning: 'PBDTFlushSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:9963)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:169: warning: 'PBDTFlushSync' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:9963)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp: In member function 'virtual nsresult nsAppleFileDecoder::Write(const char*, PRUint32, PRUint32*)':
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:268: warning: comparison between signed and unsigned integer expressions
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:281: warning: comparison between signed and unsigned integer expressions
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:438: warning: 'FSpOpenRF' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:10134)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:438: warning: 'FSpOpenRF' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:10134)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:443: warning: 'FSWrite' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8383)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:443: warning: 'FSWrite' is deprecated (declared at /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/CoreServices.framework/Frameworks/CarbonCore.framework/Headers/Files.h:8383)
../../../../../netwerk/streamconv/src/nsAppleFileDecoder.cpp:443: warning: comparison between signed and unsigned integer expressions
Assignee: nobody → valentin.gosu
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 745296
You need to log in before you can comment on or make changes to this bug.