Last Comment Bug 750691 - Permanent orange: TEST-UNEXPECTED-FAIL | test-cloudfile-backend-yousendit.js | test-cloudfile-backend-yousendit.js::teardownTest
: Permanent orange: TEST-UNEXPECTED-FAIL | test-cloudfile-backend-yousendit.js ...
Status: RESOLVED FIXED
: intermittent-failure
Product: Thunderbird
Classification: Client Software
Component: Testing Infrastructure (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: Thunderbird 15.0
Assigned To: Mike Conley (:mconley) - (needinfo me!)
:
Mentors:
Depends on:
Blocks: 787925
  Show dependency treegraph
 
Reported: 2012-05-01 06:45 PDT by Mike Conley (:mconley) - (needinfo me!)
Modified: 2012-11-25 19:31 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
WIP Patch v1 (916 bytes, patch)
2012-05-01 07:31 PDT, Mike Conley (:mconley) - (needinfo me!)
mozilla: review+
mozilla: approval‑comm‑aurora+
mozilla: approval‑comm‑beta+
Details | Diff | Review

Description Mike Conley (:mconley) - (needinfo me!) 2012-05-01 06:45:11 PDT
This has been on our nightly builds for a few days.

Aurora / Beta do not seem to be affected.  Considering that most if not all Filelink patches have simultaneously landed on Aurora and Beta, my guess is that something has changed in mozilla-central to cause this.

Another thing to note is that the test is complaining that the "Dropbox" server is failing to stop.  That's a copy-paste error - it means "YouSendIt".
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-05-01 07:31:37 PDT
Created attachment 619920 [details] [diff] [review]
WIP Patch v1

I can't reproduce this problem locally (argh), so it looks like I'll have to start bouncing patches against try to see what fixes it.

This is my first go at it - fixes the Dropbox typo, and increases the server stoppage timeout.
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-05-01 11:56:09 PDT
Hm - the failure did not appear in my try build with this patch:

http://build.mozillamessaging.com/tinderboxpushlog/?tree=ThunderbirdTry&rev=9e3261f9c72f

I'll see if I can get the tests to repeat a few times, to smoke it out.
Comment 3 Mike Conley (:mconley) - (needinfo me!) 2012-05-01 13:35:31 PDT
Wow, looks like it's gone.  I really didn't think that'd work.  Go figure.
Comment 4 Mike Conley (:mconley) - (needinfo me!) 2012-05-01 13:37:01 PDT
Comment on attachment 619920 [details] [diff] [review]
WIP Patch v1

This patch seems to do the job.  Maybe our Windows builders are just slow, and need > 5 seconds to tear down the fake HTTP server.
Comment 5 David :Bienvenu 2012-05-02 07:27:42 PDT
Comment on attachment 619920 [details] [diff] [review]
WIP Patch v1

stealing review - this is what the dropbox equivalent does, which makes me fairly confident it's going to help.
Comment 6 David :Bienvenu 2012-05-02 07:28:01 PDT
Comment on attachment 619920 [details] [diff] [review]
WIP Patch v1

[Triage Comment]

Note You need to log in before you can comment on or make changes to this bug.