Last Comment Bug 750717 - Output linker max virtual size using 'TinderboxPrint' so it will appear in the TBPL summary box
: Output linker max virtual size using 'TinderboxPrint' so it will appear in th...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All Windows Server 2003
: -- normal with 1 vote (vote)
: mozilla15
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on: 710712
Blocks: 750661
  Show dependency treegraph
 
Reported: 2012-05-01 07:14 PDT by Ed Morley [:emorley]
Modified: 2012-05-02 21:28 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.04 KB, patch)
2012-05-01 07:41 PDT, Ed Morley [:emorley]
ted: review+
philringnalda: feedback+
Details | Diff | Review

Description Ed Morley [:emorley] 2012-05-01 07:14:13 PDT
Bug 710712 added the peak virtual memory usage of the linker during the final PGO link phase on Windows to each pgo log:
http://mxr.mozilla.org/mozilla-central/source/build/link.py#53

The current output is of the form:
linker max virtual size: 3021553664

It is my understanding that if we make similar to:
TinderboxPrint: linker max virtual size: 3021553664
...it will show up in the TBPL summary box, saving us from having to open each log manually. (I imagine we'll need a shorter description string)
Comment 1 Ed Morley [:emorley] 2012-05-01 07:41:21 PDT
Created attachment 619923 [details] [diff] [review]
Patch v1

Shortened the string a bit, hopefully that's ok compared to the others used.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-05-01 07:51:01 PDT
Comment on attachment 619923 [details] [diff] [review]
Patch v1

Review of attachment 619923 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, I don't care, that was a totally arbitrary string.
Comment 3 Phil Ringnalda (:philor) 2012-05-01 08:06:46 PDT
Comment on attachment 619923 [details] [diff] [review]
Patch v1

We use tiny little strings because on Tinderbox, a long string would widen the table column and thus widen the whole page and require more horizontal scrolling to see the Windows builds. But if you remember something verbose like Talos showing failure to contact the graphserver, tbpl actually has very wide columns for showing TinderboxPrint, so that should be fine (until we're sending the raw number to graphserver, at which point that should instead TinderboxPrint a couple of digits of maxvsize/1024/1024/1024 so we don't have to remember that 2962464768 is 2.75).
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-05-02 06:36:54 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/e1f1d4f79b2d
Comment 5 :Ehsan Akhgari (busy, don't ask for review please) 2012-05-02 21:28:40 PDT
https://hg.mozilla.org/mozilla-central/rev/e1f1d4f79b2d

Note You need to log in before you can comment on or make changes to this bug.