Last Comment Bug 750728 - Rip out graphite from libxul
: Rip out graphite from libxul
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: mozilla15
Assigned To: Jonathan Kew (:jfkthame)
:
Mentors:
Depends on:
Blocks: 750661
  Show dependency treegraph
 
Reported: 2012-05-01 07:55 PDT by :Ehsan Akhgari (busy, don't ask for review please)
Modified: 2012-05-02 21:28 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Disable grapohite for now (725 bytes, patch)
2012-05-01 07:59 PDT, :Ehsan Akhgari (busy, don't ask for review please)
ted: review+
Details | Diff | Review
patch, restore graphite but move it to gkmedias.dll on windows (3.40 KB, patch)
2012-05-01 09:04 PDT, Jonathan Kew (:jfkthame)
khuey: review+
Details | Diff | Review

Description :Ehsan Akhgari (busy, don't ask for review please) 2012-05-01 07:55:00 PDT
It's that time of the year again.  We need to rip out stuff from libxul.  See bug 750661.
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2012-05-01 07:59:19 PDT
Created attachment 619931 [details] [diff] [review]
Disable grapohite for now
Comment 2 Jonathan Kew (:jfkthame) 2012-05-01 09:04:22 PDT
Created attachment 619945 [details] [diff] [review]
patch, restore graphite but move it to gkmedias.dll on windows

Something like this ought to work, I think - have pushed it to tryserver, and will request review if it builds ok.
Comment 3 Mike Hommey [:glandium] 2012-05-01 10:01:16 PDT
(In reply to Jonathan Kew (:jfkthame) from comment #2)
> Created attachment 619945 [details] [diff] [review]
> patch, restore graphite but move it to gkmedias.dll on windows
> 
> Something like this ought to work, I think - have pushed it to tryserver,
> and will request review if it builds ok.

You may have to list exported symbols in layout/media/symbols.def.in
Comment 4 Jonathan Kew (:jfkthame) 2012-05-01 11:38:08 PDT
I don't think that's needed, because of the use of GRAPHITE2_EXPORTING to get the appropriate dllexport attributes added.

Tryserver builds at https://tbpl.mozilla.org/?tree=Try&rev=24f57e880886 look happy on all desktop platforms; still waiting for android to catch up, but I believe this'll be ok.
Comment 5 Jonathan Kew (:jfkthame) 2012-05-01 12:03:50 PDT
Pushed to inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/83ff77ce8d6c

Note You need to log in before you can comment on or make changes to this bug.