Sites with flash ads are loading in upper left hand corner

VERIFIED FIXED in Firefox 14

Status

()

defect
VERIFIED FIXED
7 years ago
3 years ago

People

(Reporter: tchung, Assigned: snorp)

Tracking

Trunk
Firefox 15
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 verified, blocking-fennec1.0 +, fennec14+)

Details

()

Attachments

(2 attachments, 1 obsolete attachment)

Posted image screenshot
On sites with flash ads, they are loading in the upper left hand corner of the screen.   See URL for example

Attaching screenshot:

Repro:
1) install 5-1-2012 nightly or aurora inbound build, HTC Incredible S, Android 2.3.4
2) go to url.  really any site that has flash ads (eg. www.marketwatch.com)
3) tap to play flash ads
4) Verify the flash ads will play and appear in the upper left hand corner of the screen.

Expected:
- Flash ads should load within its specified div

Actual;
- Flash ads appear in the upper left hand corner
nom'ing cause this is not an expected experience.   likely regression.
blocking-fennec1.0: --- → ?
Adding test-case wanted because the bug URL has dynamic content likely to change
Keywords: testcase-wanted
tracking-fennec: --- → 15+
blocking-fennec1.0: ? → -
given this is blocking bug 727116 (marked release+), and a lot of sites using iframes will see this, i'd like to renom for fx14 triage.
tracking-fennec: 15+ → ?
blocking-fennec1.0: - → ?
tracking-fennec: ? → 14+
blocking-fennec1.0: ? → +
Assignee: nobody → snorp
Duplicate of this bug: 751768
Comment on attachment 620726 [details] [diff] [review]
Fix Android plugin positioning when iframes are used

Review of attachment 620726 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/plugins/base/nsPluginInstanceOwner.cpp
@@ +2868,5 @@
>  
> +// Modified version of nsFrame::GetOffsetToCrossDoc that stops when it
> +// hits an element with a displayport (or runs out of frames)
> +static nsPoint
> +GetOffsetToRootIgnoreDisplayPort(nsIFrame* aFrame)

GetOffsetToFrameWithDisplayPort?
Attachment #620726 - Flags: review?(blassey.bugs) → review+
Attachment #620726 - Attachment is obsolete: true
Target Milestone: --- → Firefox 15
Comment on attachment 621046 [details] [diff] [review]
Fix Android plugin positioning when iframes are used

[Triage Comment]
Attachment #621046 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/be4204d482a2
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Blocks: 753669
Comment on attachment 621046 [details] [diff] [review]
Fix Android plugin positioning when iframes are used

Oh god this is horrible.
Comment on attachment 621046 [details] [diff] [review]
Fix Android plugin positioning when iframes are used

If this code stays in the tree for long I will be a very sad fellow.
(In reply to Timothy Nikkel (:tn) from comment #15)
> Comment on attachment 621046 [details] [diff] [review]
> Fix Android plugin positioning when iframes are used
> 
> If this code stays in the tree for long I will be a very sad fellow.

First of all, thank you for the helpful and constructive comments. Truly illuminating.

Second, thanks for volunteering to fix it up. We really need someone from layout that knows this stuff better than I.
Unable to reproduce on on Nightly 15.0a1 (2012-05-20)
                          Aurora 14.0a2 (2012-05-20)
Samsung Galaxy SII (2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.