Closed Bug 750778 Opened 7 years ago Closed 7 years ago

Flash plugins don't move while scrolling after switching tabs

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- verified
firefox15 --- verified
blocking-fennec1.0 --- +

People

(Reporter: martijn.martijn, Assigned: snorp)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Tested on the Samsung Galaxy SII on the latest trunk build.

I suspect this is a regression from bug 727116, since a special Aurora build also contains the fix for that bug and also shows this bug.

Steps to reproduce:
- Go to http://people.mozilla.com/~mwargers/tests/plugins/flash/flashembed.html
- Make sure Flash plugins are running on that page and zoom in, so you can scroll on that page.
- Open a new tab and switch to that tab (or just switch directly to that tab)
- Switch back to the tab with the testcase
- Do some scrolling on that page

Expected result:
- Flash plugins scroll along with the page

Actual result:
- Flash plugins stay on a fixed position

Video here: http://www.youtube.com/watch?v=T4bS6kxajhY
blocking-fennec1.0: ? → +
Keywords: regression
Assignee: nobody → snorp
Neither snorp nor I can reproduce this. Can anyone other than Martijn see it?
blocking-fennec1.0: + → ?
Keywords: qawanted
Attached image screenshot
HTC Desire HD, 2.3.4, 5-02-nightly.

REpro:
1) Start by first using STR in bug 750760, comment 1.  Get the Flash ads into the corner of the screen like the screenshot there.  (test URL there)
2) tap awesomebar, and goto about:firefox
3) verify flash objects overlay, and you can pan up and down the about:firefox page with the flash ads locked into place.
Keywords: qawanted
Can you restest with an inbound build? I want to see if bug 750760 will fix this too.
blocking-fennec1.0: ? → +
Keywords: qawanted
Still reproduces on 05-04 inbound.   Except this time the steps are a little different

1) load video with iframe flash, click to play
2) switch to a tab with no flash
3) switch back to first video page.   
4) pan the page, and notice flash videos dont move. 

Screencast!  http://youtu.be/PLjgldgZ2s8
blocking-fennec1.0: + → ?
i reverted the blocking flag on accident.  can someone + again?
Keywords: qawanted
Re-set blocking-fennec1.0+
blocking-fennec1.0: ? → +
Duplicate of this bug: 753669
Comment on attachment 622060 [details] [diff] [review]
Ensure PluginLayer is always present when plugin is visible

Review of attachment 622060 [details] [diff] [review]:
-----------------------------------------------------------------

::: mobile/android/base/gfx/LayerRenderer.java
@@ +275,5 @@
>          return mMaxTextureSize;
>      }
>  
>      public void addLayer(Layer layer) {
>          LayerController controller = mView.getController();

This looks to be unused

@@ +287,5 @@
>          }
>      }
>  
>      public void removeLayer(Layer layer) {
>          LayerController controller = mView.getController();

this looks to be unused
Attachment #622060 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/0f2444af3a1d
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 622060 [details] [diff] [review]
Ensure PluginLayer is always present when plugin is visible

[Approval Request Comment]
Trivial patch, fixes easy-to-reproduce and highly visible bug. Mobile only. Low risk.
Attachment #622060 - Flags: approval-mozilla-aurora?
Verified fix on nightly, 05-14-2012.
Status: RESOLVED → VERIFIED
Comment on attachment 622060 [details] [diff] [review]
Ensure PluginLayer is always present when plugin is visible

approving for aurora since it's verified on nightly.
Attachment #622060 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified on 2012-05-17 Aurora build and 14 Beta 2.
You need to log in before you can comment on or make changes to this bug.