[Regression] Opening the same social link does not open the browser

RESOLVED FIXED in M3

Status

Pancake
Front-end
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: st3fan, Assigned: gordonb)

Tracking

unspecified
x86
Mac OS X

Details

(Reporter)

Description

6 years ago
Open a link from the social feed. When the page has loaded, click the home button. Click the same link again.

The frontend is expected to send a viewer:show message to switch the app back to the browser view. But it doesn't.

This does work from other links like the top stacks it seems.
(Reporter)

Updated

6 years ago
Summary: [Regression] Opening the same social link does open the browser → [Regression] Opening the same social link does not open the browser
(Reporter)

Updated

6 years ago
Assignee: nobody → sfoster
The navigate message fired by loading about:blank seems to have confused all our state setting/checking logic. Ignoring those in top.app gives us the expected behaviour. Fixed in https://bitbucket.org/mozillapancake/pancake/changeset/9d67f7168dd8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
This is happening again for me. To reproduce:

1) Click on a social link. Wait until it has loaded.
2) Click on the home button to go back to the main screen.
3) Click on the same social link

Expected: the browser is opened
Actual: nothing happens
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
It looks like the handling of social:create in drawer.app, and routing in general in the drawer has been pretty much rewritter, so I'm  assigning to gordon as he-touched-this-last
Assignee: sfoster → gbrander
(Assignee)

Comment 4

6 years ago
Fixed by https://bitbucket.org/mozillapancake/pancake/changeset/2b6f8134b852.

Removed showViewer code from promise chain that is kicked off for toStackAndPlace. While this is a nice bottleneck to place it in, it is not always fired. If a navigate is issued for a route that is already active, nothing will happen (and rightly so). The problem is that showViewer is a side-effect that we want to happen regardless. Composed showViewer with router event handlers. For navigation triggered by click handlers, added call to showViewer.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.