ELFLoader not compatible with Android 9+ (2.3+)

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: jesup, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

With --with-android-version 9, I got this error from Try:

mozglue/linker/ElfLoader.cpp:597: error: no matching function for call to 'sigaltstack::sigaltstack(NULL, stack_t*)'

This is relevant since WebRTC needs OpenSLES, which is only available on Android-9 and above.  Even testing WebRTC under Android is blocked; if I can have a not-for-release patch I could at least move forward until this is really resolved (and we decide to require 2.3).
Blocks: 750869
You need to set --with-android-platform in your mozconfig.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
No longer blocks: android-webrtc, 750869
You need to log in before you can comment on or make changes to this bug.