Changing theme causes additional window to be created

VERIFIED FIXED

Status

Core Graveyard
Skinability
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Ian Neal, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

17 years ago
On win32 buildID 2001040604 changing theme through View, Apply Theme dialog
causes an additional E Banking service login window to appear which it shouldn't
do.
over to skinability... Probably has to do with the page being reloaded when we 
change themes...
Component: Themes → Skinability

Comment 2

17 years ago
changing to skinablity, this is not theme issue. Reassign to Blake.
QA Contact: pmac → blakeross

Comment 3

17 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001050104

Marking as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

17 years ago
Platform: PC
OS: Windows 98SE
Build: Win32 2001050204

If it was fixed in build 2001050104 then it's broken again in 2001050204!!!
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

17 years ago
WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
I don't know how you have managed to check to see if it works recently because
of bug 82245
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

17 years ago
Tested on win 32 build ID 2001060604

Steps to reproduce
1. Go to URL
2. Wait for 2nd window to load (a login window)
3. Change theme by View, Apply theme

Expected results
1. Two open windows change theme

Actual results
1. Two open windows change theme and a third window is created (a second login
window).
OK.  This is _definitely_ due to the page being reloaded on a theme 
change.
Whiteboard: DUPEME

Comment 9

17 years ago
This WFM 2001062504 on Win 98.  Re-open if this is still an issue on the most 
recent nightly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 10

17 years ago
This should only be fixed on the branch due to fix of bug 84344 that should be
just in branch but is currently on trunk too, so reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 11

17 years ago
This works now that you have to restart the browser to see the theme switch, right?
(Reporter)

Comment 12

17 years ago
Sort of fixed I suppose
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Verified FIXED using build 2006-01-04-09 of SeaMonkey trunk on Windows XP.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.