Status

Mozilla Reps
reps.mozilla.org
P1
critical
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: stephend, Assigned: giorgos)

Tracking

({perf})

0.3.5 - Amanda

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
This should be a blocker for at least 0.3, IMHO; the /people page can take upwards of 21 seconds to load:

http://www.webpagetest.org/result/120501_9N_468F3/

We tried to address this a bit in bug 735867, but since we have the great problem of continually adding more awesome Mozilla Reps, page performance keeps spiraling.
(Reporter)

Updated

6 years ago
Keywords: perf
See Also: → bug 735867
(Reporter)

Comment 1

6 years ago
Created attachment 620144 [details]
Screenshot of webpagetest.org perf report for production
(Assignee)

Comment 2

6 years ago
On version 0.2.5 we pushed today the loading time is down to 16sec (13 sec for second view). 

Still needs work but it's definitely an improvement ;)

http://www.webpagetest.org/result/120523_SG_ESD/
(Assignee)

Comment 3

6 years ago
Created attachment 626480 [details]
Page load test 23/5
(Assignee)

Updated

6 years ago
Duplicate of this bug: 763401
(Assignee)

Updated

6 years ago
Summary: People page can take upwards of 21 seconds to load → Speed up /people/ page
(Assignee)

Updated

6 years ago
Depends on: 763528
(Assignee)

Updated

6 years ago
Depends on: 763885
(Assignee)

Updated

6 years ago
Assignee: nobody → giorgos
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Depends on: 771770
(Assignee)

Updated

5 years ago
Depends on: 776464
(Assignee)

Updated

5 years ago
Version: 0.3 - Sarek → unspecified
(Assignee)

Comment 5

5 years ago
Here is a last run from version 0.2.5 of the website so we can compare results when we deploy 0.3

http://www.webpagetest.org/result/120730_3X_98C/
(Assignee)

Updated

5 years ago
Priority: -- → P1
Version: unspecified → 0.3.5 - Amanda
(Assignee)

Updated

5 years ago
Depends on: 771909
(Assignee)

Updated

5 years ago
Blocks: 784307
(Assignee)

Updated

5 years ago
No longer blocks: 784307
Depends on: 784307
(Assignee)

Updated

5 years ago
Depends on: 784658
(Assignee)

Comment 6

5 years ago
With remo release v0.3.4 we have caching in place and gradual load of reps. The page is fast now! :)

Closing this one as fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
Created attachment 658142 [details]
Post-fix screenshot
(Reporter)

Comment 8

5 years ago
Verified FIXED:

http://www.webpagetest.org/result/120904_ZF_ERX/

Nice work, guys!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.