firefox 12.0 doesn't retain cookie or pop-up exceptions after firefox closes.

RESOLVED DUPLICATE of bug 702415

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 702415
6 years ago
6 years ago

People

(Reporter: joelfishman.pmet1, Unassigned)

Tracking

12 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Under Options | Privacy,  and Options | Content, entered cookie and pop-up exceptions. This was a clean install of Firefox 12.0 on a new computer.


Actual results:

after closing firefox and reopening, both exception fields are blank. Never had this problem with previous versions.  Removed firefox 12 (completely, including profiles) and reinstalled, same behavior.


Expected results:

configuration of exceptions lists should survive closing and restarting the application or they are useless.

Comment 1

6 years ago
If you have "Clear History when Firefox closes" box ticked in this dialog:
https://support.mozilla.org/media/uploads/gallery/images/2011-02-03-06-25-24-9a2697.png

Is the "Site Preferences" box ticked in this dialog that opens when you click the "Settings" button?
https://support.mozilla.org/media/uploads/gallery/images/2011-02-03-06-25-43-c0b014.png
(Reporter)

Comment 2

6 years ago
(In reply to Mardeg from comment #1)
> If you have "Clear History when Firefox closes" box ticked in this dialog:
> https://support.mozilla.org/media/uploads/gallery/images/2011-02-03-06-25-24-
> 9a2697.png
> 
> Is the "Site Preferences" box ticked in this dialog that opens when you
> click the "Settings" button?
> https://support.mozilla.org/media/uploads/gallery/images/2011-02-03-06-25-43-
> c0b014.png

Yes and Yes, but clear history details has "cookies" unchecked. These same settings worked in ver. 11 and earlier. Clearing any history shouldn't delete preferences.
(Reporter)

Comment 3

6 years ago
Ok, so testing confirms that unchecking "Site Preferences" keeps the exception lists using FF12 and win7.

1) Was it different with FF11 and XPSP3? I copied my settings from another system that was working properly.

2) I still think that this isn't proper behavior under "clear history" options, but having looked at other Mozilla comments I can see that I'm not alone in this opinion.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702415
You need to log in before you can comment on or make changes to this bug.