error moving message from imap folder to local folders puts it in Trash

RESOLVED INCOMPLETE

Status

--
critical
RESOLVED INCOMPLETE
7 years ago
2 years ago

People

(Reporter: domaggi, Unassigned)

Tracking

({dataloss, regression, regressionwindow-wanted})

x86
Windows 7
dataloss, regression, regressionwindow-wanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression:TB12][needs protocol log])

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

i move message from imap folder to local folder.


Actual results:

the message will be moved in trash folder of the server and i view the void message in the local folder.


Expected results:

the message should be moved in local folder.
this error happens from version 12. with the version 11 it work fine.

Comment 1

7 years ago
How do you attempt to move the messages?
(Reporter)

Comment 2

7 years ago
i click with right button on message, then i try it with "copia in" and "sposta in" and olso "archivia". (italian version)
the bug is only in release 12
i come back to release 11 and work fine

Comment 3

7 years ago
Does this happen with any local folder? Do you have your imap folders configured for offline use, so that we store a copy of the message locally? What's your imap server? An IMAP:5 protocol log https://wiki.mozilla.org/MailNews:Logging will show us what's happening with the message on the server (i.e., are we storing the deleted flag, and the server is interpreting that as the message being in the trash, or are we actually moving it to the trash folder on the server?).

Does the message look OK when you view it in TB, before you move it?
(Reporter)

Comment 4

7 years ago
yes, this happens with all local folder.
yes, it is configured for offline use.
yes, i read well the message before i move it.
i have try to create a log but the file isnt create (sorry)
(Reporter)

Comment 5

7 years ago
i have attach the imap.log
(Reporter)

Comment 6

7 years ago
Created attachment 620603 [details]
as you have request
Component: Folder and Message Lists → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: folders-message-lists → networking.imap
Whiteboard: [has protocol log]

Comment 7

6 years ago
the log shows us adding the deleted flag to the message, not moving it to the imap trash, so the only reason I can think you're seeing it in your server's trash folder is something going on with your imap server.

When you say you see "the void message" in the local folder, does that mean the message is empty in the folder you're trying to move the message to?
(Reporter)

Comment 8

6 years ago
i generate the log with the 11.0.1
with this release all work fine.
i have problem with the release 12.
obviously after the problem i come back to release 11.

when i say "the void message" it means that the message loose the subject and the text of the email.

Comment 9

6 years ago
a protocol log from tb 11 isn't helpful, unfortunately.
Whiteboard: [has protocol log]

Comment 10

6 years ago
This could have been already solved in Bug #522675 (in TB 15), see also Bug #792198 .

Comment 11

6 years ago
(In reply to beanladen from comment #10)
> This could have been already solved in Bug #522675 (in TB 15), see also Bug
> #792198 .

Indeed. Domenico do you still see this problem
Severity: normal → critical
Flags: needinfo?(domaggi)
Keywords: dataloss
Whiteboard: [closeme 2013-03-20 dup 522675]
(Reporter)

Comment 12

6 years ago
yes, i'm using the stable version 11.0.1.
each time is publish a new version of thunderbird i try but in each version the problem persist.
Flags: needinfo?(domaggi)

Comment 13

6 years ago
Domenico, is version 11 better in this regard than current stable 17? Is that why you still use it?
(Reporter)

Comment 14

6 years ago
yes

Comment 15

6 years ago
so you get a blank, empty message in the local folder?

protocol log was from versoin 12?
Keywords: regression
Summary: error moving message from imap folder to local folders → error moving message from imap folder to local folders puts it in Trash
Whiteboard: [closeme 2013-03-20 dup 522675] → [regression:TB12]

Comment 16

6 years ago
Isn't version 12 the one where pluggable mailstores landed?
(Reporter)

Comment 17

6 years ago
yes, but the problem persist yet in the last version.
the last working release was the 11.0.1

Comment 18

5 years ago
Bug 776076 is one TB12 regression bug (still open). I am pretty sure there are others.  (Bug 754799?)

Comment 19

4 years ago
Domenico, If version 11 works and verison 12 fails should be relatively easy to find the regression range.  Once we find the regression range, it should be much easier to get a fix.

First you would want to back up you thunderbird profile. Then, you want to do a binary search to find which is the last daily build X that works and X+1day fails. 

The first daily of version 12 is
F https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2011/12/2011-12-22-03-00-31-comm-central/
the last is 
L https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/01/2012-01-31-03-00-36-comm-central/
the midpoint is roughly
M https://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2012/01/2012-01-11-03-04-45-comm-central/

You want to start with the midpoint, M. If M fails then you want to test the midpoint M1 between F and M. If M1 also fails, then you test the midpoint between F and M1. etc  (but if M had worked, then you test the midpoint of M and L.)

With any luck you'll test less than 6 builds.  I hope you can test. Please let us know if you need any help.

Note - bug 402392 pluggable stores landed in two pieces - the biggest on 2011-12-24, a tiny piece on 2011-12-27.  If bug 402392 broke you, then 2011-12-24 build should work and 2011-12-25 should fail.
Flags: needinfo?(domaggi)
Keywords: regressionwindow-wanted
Removing myslef on all the bugs I'm cced on. Please NI me if you need something on MailNews Core bugs from me.

Comment 21

2 years ago
Domenico, we need both a protocol log from v12 or newer, and a regression range. Until we have more info => incomplete

https://mzl.la/2lbKdNw  TB12 regression bugs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(domaggi)
Resolution: --- → INCOMPLETE
Whiteboard: [regression:TB12] → [regression:TB12][needs protocol log]
You need to log in before you can comment on or make changes to this bug.