Closed Bug 7511 Opened 21 years ago Closed 20 years ago

IMAP: Unsubscribed parent w/child folders is not recognized

Categories

(MailNews Core :: Networking, defect, P3)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: lchiang, Assigned: Bienvenu)

References

Details

Attachments

(1 file)

IMAP:  Unsubscribed parent w/child folders is not recognized

1) In 4.x, I have a parent folder (top level) with child folders.  The parent
folder is not subscribed to.

2) In 5.0, the parent folder and the child folder are not displayed in the
folder pane.  In the IMAP log file, the line:

* LSUB (\HasChildren)

is missing for the parent folder although all the child folders are listed.

We should behave the same way as 4.x where the parent folder doesn't have to be
subscribed to if there are child folders.
Attached file IMAP log file
QA Contact: lchiang → scurtis
I forget to mention that all the child folders are subscribed to.
adding the rest of the imap gang to the list.
Target Milestone: M9 → M12
triaging to m12.
QA Contact: scurtis → lchiang
<Change QA contact from scurtis to lchiang - for now>
Moving all Mail/News Networking bugs to Mail/News Networking-Mail

This may re-open previously Verified bugs due to a Bugzilla bug...if so, I will
fix those bugs.
Target Milestone: M12 → M14
Assignee: mscott → bienvenu
Status: NEW → ASSIGNED
I'll take this.
*** Bug 22402 has been marked as a duplicate of this bug. ***
*** Bug 22562 has been marked as a duplicate of this bug. ***
(I'll ask Jan to add this bug report to the "most frequent bugs" list posted to
mozilla.org)
*** Bug 22568 has been marked as a duplicate of this bug. ***
QA Contact: lchiang → huang
Change QA Contact to me. Cc:Lisa.
I'm going to fix this soon - all the dup bugs are costing everybody a lot of
time.
Blocks: 20879
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed, at least for the netscape imap server. Any UW user out there who's seen
this problem, please try a build from 1/8 or later and let me know if it's fixed
for you.
I'll try to verify for UW-IMAP-Server.
Yes, works for me now. Thanks!
great, thanks for checking!
*** Bug 15249 has been marked as a duplicate of this bug. ***
Verified on WinNT 2000-01-13-15-M13 commercial build:
I can see Unsubscribed parent w/subscribed child folders are all displayed on
5.0 now....
Need to verify on Linux & Mac for latest better commercial build.
David, from Linux 2000-01-11-10-M13 commercial build:
I didn't see "unsubscribed parent w/subscribed child folders" displaying on
5.0?! Are you sure that this problem have been fixed for All the OS/platforms?
huang, I'm using Linux.
Yes. Thanks.
I still need to verify on all the platform.
I think what bucksch is saying is that it worked for him on Linux, whereas you
were saying it didn't work for you on Linux. No, there's nothing
platform-specific about my fix. It should work fine on Linux.
I cannot attach the IMAP log for some reason....
So I copied some of the log file:

I have unscribed parent1 folder & subscribed sub folders: parent11, parent21,
parent31....the log file seems fine but just not displayed on the UI for Linux.

Can you try again since it worked fine on WinNT....

3076[8977f88]: nsmail-5:A:CreateNewLineFromSocket: * LSUB (\HasNoChildren) "/"
parent1/parent11
3076[8977f88]: nsmail-5:A:CreateNewLineFromSocket: * LSUB (\HasNoChildren) "/"
parent1/parent21
3076[8977f88]: nsmail-5:A:CreateNewLineFromSocket: * LSUB (\HasNoChildren) "/"
parent1/parent31
> Can you try again since it worked fine on WinNT....
If you mean me: Unfortunately, I can't, my last build (from yesterday) doesn't
show *any* folder, not even the INBOX. I'll tell you, if it works again.
huang,

my Mailnews works again.

Try to stop Mozilla, |rm -rf ~/.mozilla/<ProfileName>/ImapMail/*| and rerun

Mailnews.
Thanks for the info.
Actually, I removed ".mozilla" directory totally every time for verifying this
bug....
It seems that today's Linux commercial build has progress...
The "unsubscribed parent w/subscribed child folders" are displaying on the 5.0
UI now.....I will verify on Mac once we have good Mac commercial build....
Status: RESOLVED → VERIFIED
Verified on the latest good Mac 2000-01-14-15-M13 commercial build.
Great!! The "unsubscribed parent w/subscribed child folders" are displaying on
the Mac now....Good improvement!! Marking as verified!!
Target Milestone: M14 → M13
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.