Last Comment Bug 751265 - Clean-up android mozconfigs
: Clean-up android mozconfigs
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks: 757909
  Show dependency treegraph
 
Reported: 2012-05-02 11:06 PDT by Mike Hommey [:glandium]
Modified: 2012-05-23 11:25 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Let configure script derive toolchain and platform instead of hardcoding in mozconfig (9.16 KB, patch)
2012-05-15 01:56 PDT, Mike Hommey [:glandium]
blassey.bugs: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-05-02 11:06:01 PDT
Bug 750865 is a typical problem that can happen thanks to our current defaults:
you can set --with-android-version, and have it out-of-sync with --with-android-platform as set in mozconfig. We should remove --with-android-platform, which configure is able to derive, and set --with-android-version. There are other flags that we can probably remove at the same time, because they are derived from other values, too.
Comment 1 Mike Hommey [:glandium] 2012-05-15 01:56:01 PDT
Created attachment 623978 [details] [diff] [review]
Let configure script derive toolchain and platform instead of hardcoding in mozconfig

try: -b do -p android,android-xul -u none -t none
Comment 3 Ed Morley [:emorley] 2012-05-23 08:08:22 PDT
https://hg.mozilla.org/mozilla-central/rev/d2635f3f4770

Note You need to log in before you can comment on or make changes to this bug.