Javascript URL causes what's related to update

VERIFIED DUPLICATE of bug 57675

Status

SeaMonkey
Sidebar
VERIFIED DUPLICATE of bug 57675
18 years ago
14 years ago

People

(Reporter: Paul McGarry, Assigned: matt)

Tracking

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2 i686; en-US; 0.8.1)
BuildID:    2001040608

Clicking on a javascript url in a page causes the "What's Related" sidebar to
update and give a badurl message.
The "What's Related" sidebar should only update when the url in the urlbar
changes (with the exception of #anchors within a page) not with every click on a
link.

Note that this is different to bug 57675 which is about displaying a better
error message when "What's Related" can't do it's job. In this case, "What's
Related" shouldn't even be trying to do anything.

Reproducible: Always
Steps to Reproduce:
1. Visit URL
2. Click on "Click Here" javascript URL


Actual Results:  "What's related" attempts to update

Expected Results:  What's related shouldn't update.

Comment 1

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

17 years ago
need to check what's related code for javascript:
Target Milestone: --- → mozilla1.0

Comment 3

17 years ago
Dup of bug 57675?

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 57675 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.