If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

focusing on the login textbox on m.facebook.com pans the site past where the page ends

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: blassey, Assigned: mats)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 fixed, blocking-fennec1.0 .N+, fennec15+)

Details

(Whiteboard: [layout][worksforme?])

Attachments

(2 attachments)

Created attachment 620456 [details]
screenshot

STR:
1) load m.facebook.com
2) touch username field

ER: no horizontal panning (viewport meta tag should disallow it)
AR: noticeable white bar down the right side because we've panned past where the page ends
(Reporter)

Updated

6 years ago
Assignee: nobody → bugmail.mozilla
blocking-fennec1.0: ? → +
This seems to be a layout problem rather than a viewport issue. It's not that we pan the page, it's that the content actually shifts over to the left when we call scrollIntoView(false) on the text input.

I can reproduce this behaviour in desktop firefox by doing the following:

1. Install the UA switcher addon and add the Fennec 15 UA string and make it default
2. Resize the browser window to 360px wide (I think any width less than ~450px works for this)
3. Open the web console and run document.querySelector("input[type=text]").scrollIntoView(false)

Note how the page content gets shifted over and the white bar is visible down the right side, and the page is still not horizontally scrollable. Using Firebug to examine the layout properties of the various elements on the page shows no difference before and after step 3 above, so I'm not sure what's going on here. Widening the window and narrowing it again clears the white bar and allows doing step 3 again to reproduce.

Re-noming since I'm not sure this should be blocking for fennec; it should also be moved to core layout, maybe.
blocking-fennec1.0: + → ?
Created attachment 621131 [details]
Screenshot from desktop FF showing the same issue
(Reporter)

Updated

6 years ago
Assignee: bugmail.mozilla → nobody
blocking-fennec1.0: ? → +
Component: General → Layout
Product: Fennec Native → Core
QA Contact: general → layout
Jet, can you hand this out?
Assignee: nobody → jet

Comment 4

5 years ago
To Mats for a look...
Assignee: jet → matspal

Updated

5 years ago
Whiteboard: [layout]
Blocks: 759986
(Reporter)

Updated

5 years ago
blocking-fennec1.0: + → .N+
(Reporter)

Updated

5 years ago
tracking-fennec: --- → 15+
(Assignee)

Comment 5

5 years ago
Works for me, both in a current Nightly and the latest beta on Android.
(I did reproduce it a couple of weeks ago though, iirc)

Can anyone else still reproduce the problem?
Whiteboard: [layout] → [layout][worksforme?]
works for me as well
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
status-firefox14: --- → fixed
You need to log in before you can comment on or make changes to this bug.