Closed Bug 751402 Opened 8 years ago Closed 8 years ago

Forum thread causes Firefox to rapidly consume all system memory

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 634444

People

(Reporter: TimAbraldes, Unassigned)

References

()

Details

(Whiteboard: [MemShrink])

Attachments

(2 files)

The attached URL, when visited in the current Nightly build of Firefox, causes Firefox memory usage to rapidly increase without any sign of stopping.  On my machine with 8GB RAM and 20GB of page file, the RAM was quickly exhausted and the machine became unusable (presumably as the page file churned).

I tested the same web page in Chrome and IE and the problem did not reproduce there.
The same web page, when loaded in Firefox 10, causes Firefox to become unresponsive for a few seconds, but does not consume all my machine's memory.

In Firefox 12, firefox's memory consumption grew to about 3.5GB but then dropped immediately back to a normal amount.

The current Aurora build (Firefox 14) acts the same as Firefox 12 on this page.
Actually I've been using 64-bit Nightly but 32-bit Aurora and Firefox.  It's likely that the bug here is "this page causes firefox to consume 3.5GB of memory, more (double?) in 64-bit builds"
Whiteboard: [MemShrink]
I just tried this with a FF15 dev build on 64-bit Linux, and the page loaded without any troubles.  "resident" memory didn't go above 130MB and was stable.

Tim, are you able to get an about:memory snapshot before Nightly becomes unusable?
(In reply to Nicholas Nethercote [:njn] from comment #3)
> I just tried this with a FF15 dev build on 64-bit Linux, and the page loaded
> without any troubles.  "resident" memory didn't go above 130MB and was
> stable.

I wonder if this is a Windows-only issue?

> Tim, are you able to get an about:memory snapshot before Nightly becomes
> unusable?

I'm not able to; while the memory is being allocated Firefox is completely unresponsive to input.


For completeness, I've verified that this issue occurs in safe mode (all addons disabled).
This bug does NOT present itself when I use a different profile.  Perhaps this is related to some pref I have set in my default profile?

I've again verified that this issue still exists when I disable all plugins and extensions.

I still haven't been able to capture about:memory while this issue is manifesting (since Firefox seems to be too busy allocating memory to respond to my input), but I did capture a couple logs with memchaser.  Not sure if those are helpful but I'll attach them anyway.
Through bisection I've discovered the pref that causes this issue:
  javascript.options.strict

Steps to reproduce:
  Set "javascript.options.strict" to "true"
  Visit http://www.teachexcel.com/excel-help/excel-how-to.php?i=162116
  Watch as Firefox consumes many GB of memory

I'm not sure what that pref is intended to do (though I must have had reason to set it at some point), so maybe this bug is invalid.
Turning on strict mode is known to generate many more warnings/errors in web content. This in turn causes memory usage to balloon in the error console when minified scripts trigger errors, since each one causes the whole script contents to be stored for display. In short, known bug.
Whiteboard: [MemShrink] → [MemShrink] DUPME
Ah, this old friend.  The good news is that I'm doing a bunch of work in the JS front-end at the moment, which is reacquainting me with the code that needs to be changed in bug 634444.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: [MemShrink] DUPME → [MemShrink]
Duplicate of bug: 634444
You need to log in before you can comment on or make changes to this bug.