survey all releng systems for uses of the sjc1 DB VIPs

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: dustin, Assigned: dustin)

Tracking

Details

I found two systems using sjc1 IPs today: clobberer and slavealloc.

We need to run through everything releng and make sure it's all talking to the new DB.

Sheeri, do you have any reports or anything that might help?  I can probably guess 95% of the places we might be using the wrong VIPs, but any help with that last 5% would be great.
Assignee: server-ops-releng → dustin
Dustin - if a system is running MySQL 5.1 or later I can turn on general logging easily (if it's 5.0 I can do it, but it requires a mysql restart), and figure out where people are coming from - which would be what VIP they're coming from.

If you have a list of database clusters, (I'm thinking bouncer, b1 cluster, b02 cluster at least) I can work on that - turn on general logging for a day, then see what's still coming from SJC.

also I can look to make sure they're all using VIPs as opposed to coming directly to the machines themselves.
Depends on: 751586
Depends on: 751615
Depends on: 751617
My notes:

relengweb1.dmz.scl3:
 /data/www/clobberer-stage/clobberer_creds.php
 /mnt/netapp/relengweb/oldstuff/var-www-html/build/stage-clobberer/clobberer_creds.php
  - flows: open already
  - ACLs: bug 751579

slavealloc.build.scl1:
 /builds/slavealloc/staging-1079/slavealloc.tac
 /builds/slavealloc/production-1080/slavealloc.tac
  - flows: bug 751615
  - ACLs: bug 751617

buildapi01.build.scl1:
 /home/buildapi/production.ini
  - OK

autoland-staging01.build.scl1:
autoland-staging02.build.scl1:
 to be decommed in bug 751591
 uses local sqlite db anyway, AIUI
  - OK

buildbot-master30.srv.releng.scl3:
  - OK

cruncher.srv.releng.scl3:
 /home/*, basically.  I'll leave this to the owners of each homedir to update as necessary.  The URLs used are
  mysql://buildbot_reader:<elided>@tm-b01-slave01.mozilla.org/buildbot
  mysql://buildbot_reader:<elided>@tm-b01-slave01.mozilla.org/buildbot_schedulers
  mysql://buildbot:<elided>@tm-stage01-slave01.mozilla.org/scheduler_staging
  mysql://buildslaves:<elided>@tm-b01-master01.mozilla.org/buildslaves
  mysql://buildslaves:<elided>@tm-b01-slave01.mozilla.org/buildslaves
  mysql://regressdetect:<elided>@tm-b01-slave01.mozilla.org/graphs_mozilla_org_new
  - flows: open already
  - ACLs: bug 751617

[1] featured at
   http://cruncher.build.mozilla.org/~nthomas/test-utilisation/reporter.cfg
-> bug 751605
Depends on: 752096
I wrapped up clobberer and stage.  Cruncher got handled.  Lukas updated autoland-staging.  I think we're good?
Sure, Corey is going to show me later today about looking at the Zeus logs, so either close this ticket or assign it to me, and I can verify (or open a new bug if there's sjc traffic).
Verified with releng that this is done on their end.  Going to close this one and have you open new bugs if you find stragglers.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.