Last Comment Bug 751463 - [Azure] Rip Azure out of libxul
: [Azure] Rip Azure out of libxul
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla15
Assigned To: Bas Schouten (:bas.schouten)
:
:
Mentors:
Depends on:
Blocks: 751431
  Show dependency treegraph
 
Reported: 2012-05-02 21:14 PDT by Bas Schouten (:bas.schouten)
Modified: 2012-05-04 09:25 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Rip GFX2D out of Libxul (5.67 KB, patch)
2012-05-02 21:14 PDT, Bas Schouten (:bas.schouten)
khuey: review+
Details | Diff | Splinter Review

Description Bas Schouten (:bas.schouten) 2012-05-02 21:14:33 PDT
Created attachment 620577 [details] [diff] [review]
Rip GFX2D out of Libxul

Since the Azure API is almost completely virtual, it will not suffer from a lot of extra overhead if moved to gkmedia. Additionally now that Cairo and Skia are moving there, it will be a performance win, since the (non-virtual API) surface of cairo and skia is much larger than Azure's so we benefit from the Azure calls being the library boundary.
Comment 1 Bas Schouten (:bas.schouten) 2012-05-03 12:38:53 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/18f6006cce70
Comment 2 Ed Morley [:emorley] 2012-05-04 09:25:34 PDT
https://hg.mozilla.org/mozilla-central/rev/18f6006cce70

Note You need to log in before you can comment on or make changes to this bug.