Moving an item between two iCloud CalDAV calendars on the same domain results in error 409: Resource Conflict

RESOLVED DUPLICATE of bug 702570

Status

Calendar
Provider: CalDAV
RESOLVED DUPLICATE of bug 702570
6 years ago
6 years ago

People

(Reporter: tomsteg, Unassigned)

Tracking

Lightning 1.4

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120417165043

Steps to reproduce:

I opened an existing task and changed the calendar selecting an other one at the drop down. i tried to store the task and got an error.


Actual results:

error code: MODIFICATION_FAILED
description: Status-Code 409, Ressourcen-Konflikt
<?xml version='1.0' encoding='UTF-8'?><error xmlns='DAV:'><no-uid-conflict xmlns='urn:ietf:params:xml:ns:caldav'><href xmlns='DAV:'>/38422612/calendars/M2CD-4-1-D80C9143-A4B7-4514-83FF-29A83ACF210A-reminders/11e82dab-0f3d-8c44-8b7b-c6978a443798.ics</href></no-uid-conflict><error-description xmlns='http://twistedmatrix.com/xml_namespace/dav/'>(6403370732) Found component /38422612/calendars/M2CD-7-1-82508C9A-C73E-4902-A740-A306ECF530CB-reminders/11e82dab-0f3d-8c44-8b7b-c6978a443798.ics with same UID in a different collection: /38422612/calendars/M2CD-4-1-D80C9143-A4B7-4514-83FF-29A83ACF210A-reminders/11e82dab-0f3d-8c44-8b7b-c6978a443798.ics</error-description></error>


Expected results:

The Task should have been stored in the new calendar. Both calendars (old and new one) are WebDAV calendars.
That error would seem to indicate a resource conflict, meaning a task with the same id is already present in the calendar you were trying to move it to. If you restart Thunderbird is there a duplicate task shown, one per each calendar? Can you duplicate this error with a new task, or a different existing task?
(Reporter)

Comment 2

6 years ago
Sorry, but there is no duplicate task-entry, even after restart.
Both Calendars have different caldav-addresses at iCloud (Mac) on the same domain https://p01-caldav.icloud.com. The Login for both calendars is the same email an password combination.
Even when I try to switch calendars with completely new tasks, I get the same error.
Do events have the same issue, or does this only happen with tasks?
(Reporter)

Comment 4

6 years ago
Good question, because it happens also with events. 
I stored a new event, opened it again, changed the calender, tried to store it and got the same error.
Afterwards the calender, I wanted to change to, has a warning symbol (!) beneath it at the left column. After manually syncing that calendar, the warning symbol disappears.
(Reporter)

Updated

6 years ago
OS: All → Mac OS X
Hardware: All → x86_64
Component: Tasks → Provider: CalDAV
OS: Mac OS X → All
QA Contact: tasks → caldav-provider
Hardware: x86_64 → All
Summary: within a task it is not possible to change the calendar and store the task → Moving an item between two iCloud CalDAV calendars on the same domain results in error 409: Resource Conflict

Comment 5

6 years ago
Thanks for reporting this issue! However, tt has already been reported before.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 702570
You need to log in before you can comment on or make changes to this bug.