Last Comment Bug 751505 - fix and reenable toolkit/components/ctypes/tests/unit/test_finalizer_shouldaccept.js
: fix and reenable toolkit/components/ctypes/tests/unit/test_finalizer_shouldac...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: David Teller [:Yoric] (please use "needinfo")
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: cpg ctypes.finalize 745184
  Show dependency treegraph
 
Reported: 2012-05-03 02:50 PDT by Luke Wagner [:luke]
Modified: 2012-05-04 10:37 PDT (History)
6 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Better memory cleanup during the test. (1.54 KB, patch)
2012-05-03 06:01 PDT, David Teller [:Yoric] (please use "needinfo")
no flags Details | Diff | Splinter Review
Better memory cleanup during the test. (1.54 KB, patch)
2012-05-03 06:24 PDT, David Teller [:Yoric] (please use "needinfo")
jorendorff: review+
Details | Diff | Splinter Review
Better memory cleanup during the test. (1.99 KB, patch)
2012-05-03 08:11 PDT, David Teller [:Yoric] (please use "needinfo")
dteller: review+
Details | Diff | Splinter Review
Better memory cleanup during the test. (2.01 KB, patch)
2012-05-03 08:14 PDT, David Teller [:Yoric] (please use "needinfo")
dteller: review+
Details | Diff | Splinter Review

Description Luke Wagner [:luke] 2012-05-03 02:50:43 PDT
A new xpcshell test started failing with cpg (bug 650353).  Given that it is only failing on one platform (OSX 10.5 opt) and in finalization, we are suspicious of the test having some timing or order dependency.  Given that this is a new feature, it seems ok to temporarily disable the test (rather than backing out cpg and a bunch of related patches) and investigate pronto.
Comment 1 David Teller [:Yoric] (please use "needinfo") 2012-05-03 02:52:09 PDT
I will look at it.
Comment 2 David Teller [:Yoric] (please use "needinfo") 2012-05-03 06:01:57 PDT
Created attachment 620669 [details] [diff] [review]
Better memory cleanup during the test.

Propagating the cleanup introduced for bug 745233.
Comment 3 David Teller [:Yoric] (please use "needinfo") 2012-05-03 06:24:32 PDT
Created attachment 620676 [details] [diff] [review]
Better memory cleanup during the test.

Sorry for the confusion, this patch should apply cleanly.
Comment 4 Ed Morley [:emorley] 2012-05-03 07:50:35 PDT
Disabled test on inbound to green the tree up for now:
https://hg.mozilla.org/integration/mozilla-inbound/rev/94913b445e72
Comment 5 Jason Orendorff [:jorendorff] 2012-05-03 08:05:14 PDT
Comment on attachment 620676 [details] [diff] [review]
Better memory cleanup during the test.

Yup. It looks like test_to_int should be fixed up too.
Comment 6 David Teller [:Yoric] (please use "needinfo") 2012-05-03 08:11:02 PDT
Created attachment 620705 [details] [diff] [review]
Better memory cleanup during the test.

Added a second clean-up, just in case.
Comment 7 David Teller [:Yoric] (please use "needinfo") 2012-05-03 08:14:42 PDT
Created attachment 620707 [details] [diff] [review]
Better memory cleanup during the test.

Same patch, but with a newline.
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-05-03 15:41:15 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/720b32b1ef1e
Comment 9 Ed Morley [:emorley] 2012-05-04 02:24:12 PDT
(In reply to Ed Morley [:edmorley] from comment #4)
> Disabled test on inbound to green the tree up for now:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/94913b445e72

https://hg.mozilla.org/mozilla-central/rev/94913b445e72
Comment 10 Ed Morley [:emorley] 2012-05-04 10:37:16 PDT
> Created attachment 620707 [details] [diff] [review]
> Better memory cleanup during the test.

https://hg.mozilla.org/mozilla-central/rev/720b32b1ef1e

Note You need to log in before you can comment on or make changes to this bug.