Virtual keyboard appears in this case after Fennec is minimized

REOPENED
Unassigned

Status

()

P3
normal
REOPENED
7 years ago
2 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({testcase})

Trunk
ARM
Android
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: VKB, URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 620641 [details]
testcase

See testcase, steps to reproduce:
- Open testcase
- Tap on the Android home button

Expected result:
- Fennec minimized/closed

Actual result:
- Fennec minimized/closed, but vkb pops up

I can reproduce this on the Samsung Galaxy Nexus, but not on the Galaxy SII or HTC Desire HD. Perhaps ICS only?
mw22, is this a regression?

I was able to reproduce this bug intermittently on my Galaxy Nexus. Tapping input focus into and then out of the text field before pressing the home button seems to help repro.
Keywords: regressionwindow-wanted
Whiteboard: VKB
I manage to find a regression range although the behavior is slightly different:
 - The VKB pops up but only for a second then disappears.
Dev: Samsung Nexus (ICS)

This issue doesn't occur on:
Nightly 15.0a1 (2012-04-26)
http://hg.mozilla.org/mozilla-central/rev/cc5254f9825f 

but it occurs on:
Nightly 15.0a1 (2012-04-27)
http://hg.mozilla.org/mozilla-central/rev/450d8cd16316 

Possible range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cc5254f9825f &tochange=450d8cd16316
Keywords: regressionwindow-wanted
Catalin, thanks for identifying the regression window. None of the changesets stand out as obvious suspects, but changeset 3b2a389ba7ef is interesting because it changes some code related to input focus.
Priority: -- → P3
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.