Closed Bug 751523 Opened 9 years ago Closed 9 years ago

Possible leak on plusone.google.com

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 750048

People

(Reporter: misak.bugzilla, Unassigned)

Details

(Whiteboard: [MemShrink][js:waitingforinfo])

Hello,

My SeaMonkey (Build identifier: Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/15.0 Firefox/15.0a1 SeaMonkey/2.12a1) uses lot of memory (almost 50% of JS) on plusone.google.com.

about:memory excerpt:

853,773,418 B (100.0%) -- explicit
├──546,652,856 B (64.03%) -- js
│  ├──280,228,104 B (32.82%) -- compartment(https://plusone.google.com/_/+1/fastbutton?url=http%3A%2F%2Fjalopnik.com%2F5906652%2Fayrton-senna-had-a-great-sense-of-humor&size=medium&count=false&hl=en-US&jsh=m%3B%2F_%2Fapps-static%2F_%2Fjs%2Fgapi%2F__features__%2Frt%3Dj%2Fver%3Dp6d9QGKZKQ4.en.%2Fsv%3D1%2Fam%3D!UAItGHWvjEqItmX_Hw%2Fd%3D1%2Frs%3DAItRSTNxPJENqxKLd0J-SNYHCKLzmpc4_A#id=I1_1336027972813&parent=http%3A%2F%2Fjalopnik.com&rpctoken=621635405&_methods=onPlusOne%2C_ready%2C_close%2C_open%2C_resizeMe%2C_renderstart)
│  │  ├──155,811,840 B (18.25%) -- gc-heap
│  │  │  ├───63,540,864 B (07.44%) -- objects
│  │  │  │   ├──32,891,232 B (03.85%) ── non-function
│  │  │  │   └──30,649,632 B (03.59%) ── function
│  │  │  ├───39,637,216 B (04.64%) -- shapes
│  │  │  │   ├──20,590,720 B (02.41%) ── tree
│  │  │  │   ├──14,179,760 B (01.66%) ── dict
│  │  │  │   └───4,866,736 B (00.57%) ── base
│  │  │  ├───38,139,232 B (04.47%) ── scripts
│  │  │  ├────6,391,440 B (00.75%) ── type-objects
│  │  │  ├────6,159,952 B (00.72%) -- arena
│  │  │  │    ├──3,017,616 B (00.35%) ── unused
│  │  │  │    ├──1,925,056 B (00.23%) ── padding
│  │  │  │    └──1,217,280 B (00.14%) ── headers
│  │  │  └────1,943,136 B (00.23%) ── strings
│  │  ├───81,974,392 B (09.60%) ── script-data
│  │  ├───20,305,632 B (02.38%) -- shapes-extra
│  │  │   ├───6,855,168 B (00.80%) ── tree-tables
│  │  │   ├───5,958,816 B (00.70%) ── dict-tables
│  │  │   ├───3,964,928 B (00.46%) ── compartment-tables
│  │  │   └───3,526,720 B (00.41%) ── tree-shape-kids
│  │  ├───11,329,296 B (01.33%) -- type-inference
│  │  │   ├───7,525,856 B (00.88%) ── object-main
│  │  │   └───3,803,440 B (00.45%) ── tables
│  │  ├────9,291,952 B (01.09%) -- objects
│  │  │    ├──9,016,704 B (01.06%) ── slots
│  │  │    ├────235,648 B (00.03%) ── elements
│  │  │    └─────39,600 B (00.00%) ── misc
│  │  ├────1,035,904 B (00.12%) ── analysis-temporary
│  │  ├──────327,680 B (00.04%) -- mjit
│  │  │      └──327,680 B (00.04%) ── code
│  │  └──────151,408 B (00.02%) ── string-chars


It uses around 1.4G after day of use without restarting.
Whiteboard: [MemShrink]
- Does this happen only in SeaMonkey, or in Firefox too?
- Does it happen only in the latest version, or in previous versions too?
- What about other browsers?

I'm wondering whether it's a bug in Gecko, or if the site just uses a lot of memory.
Whiteboard: [MemShrink] → [MemShrink][js:waitingforinfo]
(In reply to David Mandelin from comment #1)
> - Does this happen only in SeaMonkey, or in Firefox too?

Same on Firefox trunk

> - Does it happen only in the latest version, or in previous versions too?

It starts happening about two weeks before bug reported.

> - What about other browsers?
> 
> I'm wondering whether it's a bug in Gecko, or if the site just uses a lot of
> memory.

This is IMHO related with Google Reader and G+ button there.
(In reply to Misak Khachatryan from comment #2)
> (In reply to David Mandelin from comment #1)
> > - Does this happen only in SeaMonkey, or in Firefox too?
> 
> Same on Firefox trunk
> 
> > - Does it happen only in the latest version, or in previous versions too?
> 
> It starts happening about two weeks before bug reported.

Thanks. Would you be able to bisect this to find out in which Nightly build the bug started? 

> > - What about other browsers?
> > 
> > I'm wondering whether it's a bug in Gecko, or if the site just uses a lot of
> > memory.
> 
> This is IMHO related with Google Reader and G+ button there.

The bisection can probably help answer this question: if you can bisect to a given date, then it's likely a regression in Firefox.
Sorry I do not have a start date for you guys, but I too have noticed the plusone compartment issue.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/15.0 Firefox/15.0a1
ac968ff4fe41

And yes I believe its Google Reader is the main page that is causing this. Most of of the compartments are from sites I didn't open a tab for, but where in my rss feeds.
If Google Reader is the problem, this is probably a dup of bug 750048.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 750048
You need to log in before you can comment on or make changes to this bug.