wrong font applying when outsourced in a JS file

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
18 years ago
5 years ago

People

(Reporter: Markus Hübner, Assigned: jst)

Tracking

({regression})

Trunk
mozilla0.9
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
If you take a look at
http://www.prologo.at/mozillatest.htm
with the JavaScript code inside, everything is working fine.
At
http://www.prologo.at/2.htm
the same JavaScript code just outsourced to a file, but a wrong font is used.

Both files work fine in Netscape 6.01!

Using Build 2001040604
(Reporter)

Updated

18 years ago
Keywords: regression
Target Milestone: --- → mozilla0.9
The problem is that a style sheet created with 'document.writeln("<link 
rel=\"stylesheet\" ... >")' does not get applied if the call to document.writeln 
is in an external script.  Over to DOM0; this sounds like some other things we 
have along these lines...
Component: Browser-General → DOM Level 0
Whiteboard: DUPEME
reassign for real
Assignee: asa → jst
QA Contact: doronr → desale
(Reporter)

Comment 3

18 years ago
will this be fixed with the XPCDOM branch?
(Assignee)

Comment 4

18 years ago
Hmm, works for me, in any case, the XPCDOM work would not affect this. Please
reopen if you still see this, when did it start happening?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.