Playing Flash video yields black screen -- Surface::lock failed, already locked messages

VERIFIED FIXED in Firefox 14

Status

()

defect
--
major
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aaronmt, Assigned: snorp)

Tracking

({regression})

Trunk
Firefox 15
ARM
Android
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 verified, firefox15 verified, blocking-fennec1.0 +)

Details

()

Attachments

(2 attachments)

After a half dozen attempts to trigger the play button after activating plugins on Android.com, the entire viewport turns black and my log is continuously flooded with

E/Surface ( 9926): Surface::lock failed, already locked


--
Nightly (05/03), Aurora (05/03)
Samsung Galaxy Note (Android 2.3)
This leaves Fennec completely non-functional; new load attempts at new sites leave the throbber spinning and nothing happening, looping:

E/Surface ( 9926): Surface::lock failed, already locked
I suspect this is a regression from bug 727116, can QA please confirm that?
Assignee: nobody → snorp
Blocks: 727116
Keywords: qawanted
Keywords: regression
not sure yet if its a dupe of bug 750963
Blocks: 750963
No longer blocks: 750963
blocking-fennec1.0: ? → +
Summary: Playing Flash video on Android.com on the Galaxy Note yields black screen -- Surface::lock failed, already locked messages → Playing Flash video yields black screen -- Surface::lock failed, already locked messages
With the above patch, we block for a maximum of ~5ms and give up after that. The result is that you won't see the placeholder which looks nice during pan/zoom and instead the plugin SurfaceView will kind of lag behind. Sucks, but apparently there is something going on with the Note that causes a problem here.
Can reproduce on an inbound from this afternoon so 'the looper patch' didn't fix this.
Attachment #621137 - Flags: review?(blassey.bugs) → review+
http://hg.mozilla.org/mozilla-central/rev/90e8e70edff1
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 15
Comment on attachment 621137 [details] [diff] [review]
Give up on locking a Surface after 10 failures

[Triage Comment]
Attachment #621137 - Flags: approval-mozilla-aurora+
This issue is not reproducible anymore on the latest Nightly and Aurora builds. Closing bug as verified fixed on:

Firefox 15.0a1 (2012-05-30)
Firefox 14.0a2 (2012-05-30)

Device: Galaxy Nexus
OS: Android 4.0.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.