[NativeUI GA] Implement new mobile/platforms design

RESOLVED FIXED in 3.1

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jfu, Assigned: sgarrity)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
Placeholder for implementation. 

Redesigning mobile/platforms to be responsive and to update with new minimum system requirements. Will need this updated before the native UI GA launch in late Q2.

Updated

7 years ago
Blocks: 751730

Updated

7 years ago
Summary: [NativeUI launch] Implement new mobile/platforms design → [NativeUI GA] Implement new mobile/platforms design
(Reporter)

Comment 1

7 years ago
Hi malexis,

Design is done for the mobile/platforms front-end 

PSD can be found here: http://cl.ly/353i0X1922311h3Z2y0l

Want to confirm this new promo will be tracked on WebTrends 

Live date: July 9 

thanks!
(Reporter)

Comment 2

7 years ago
Sorry I meant August 6, not July 9
Is August 6 the new launch date for NativeUI GA?
(Reporter)

Comment 4

7 years ago
oh whoops sorry - I'm getting all my pages mixed up. Thanks for the catch 

This page needs to go out June 29, which is the FN14 release date
Craig, this looks like a good bug to get your feet wet on mozilla.org bedrock pages. 
Steven and James can guide you.
Assignee: nobody → craigcook.bugz
Target Milestone: --- → 2.7
(Reporter)

Comment 6

7 years ago
QA: the platforms page has been redesigned here (Bug 738358), can you provide the final list of devices for GA in this etherpad for us to implement? https://etherpad.mozilla.org/ntksdhs2K8

Updated

7 years ago
Target Milestone: 2.7 → 2.9
(Reporter)

Comment 7

6 years ago
Ping - QA/Irina can you provide this list of devices?
(Reporter)

Comment 8

6 years ago
The list of devices can be found here: https://etherpad.mozilla.org/FWCFT5rb7V

We're thinking that because this first version of native UI won't be available for tablets, we should remove the tablet section on this page until FN15. 

Are we on track to implement in time for June 26?

Thanks!

Comment 9

6 years ago
Link to PSD is here:
http://cl.ly/2b2r3m102Q3q0N2p063e

Comment 10

6 years ago
Hey Mike, what's the correct implementation bug for this? Seems like we have two - this one and bug 763653.
Some work is already happening in bug 694163, as part of the backend work on it. I'll let Steven choose which bugs he wants to keep open.
(Reporter)

Comment 12

6 years ago
List of devices can be found here: https://etherpad.mozilla.org/FWCFT5rb7V

Updated Minimum system requirements: Android 2.2 and above devices, ~512MB minimum RAM, and ~16MB of internal storage

Updated

6 years ago
Duplicate of this bug: 763653

Updated

6 years ago
Target Milestone: 2.9 → 3.1
(Reporter)

Comment 14

6 years ago
Quick note from Karen that we should not use the "~" signs when we implement. Thanks!
(Assignee)

Updated

6 years ago
Assignee: craigcook.bugz → steven
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 15

6 years ago
This page is setup and ready for review/QA in the dev branch: http://www-dev.allizom.org/b/en-US/firefox/mobile/platforms

The actual list of devices is managed in https://github.com/mozilla/bedrock/blob/dev/media/devices.csv (though that URL will change for the 'master' branch when we're in production).
Keywords: qawanted
Hi Steven,

I just submitted a small device reorganization pull request to https://github.com/mozilla/bedrock/pull/178 (did it quick, hopefully I got the right branch in there). 

Second, I have a comment in that we should be promoting Samsung, HTC and Motorola higher up from Huawei, Kyocera, LG and others due to the vast majority of Android devices and market are these those companies. Perhaps we can add some space? Thinking: [Samsung, HTC, Motorola] <br/> [Huawei, Kyocera, LG, Sony, Sony Ericsson]
(Assignee)

Comment 17

6 years ago
Aaron's device updates have been merged in. I'll wait for confirmation on how to order the list of manufacturers. It's alphabetical right now.
Jaclyn, Irina, would that sorting I mentioned in comment #16 be a good idea?

Comment 19

6 years ago
(In reply to Aaron Train [:aaronmt] from comment #18)
> Jaclyn, Irina, would that sorting I mentioned in comment #16 be a good idea?

I am not sure whether from a usability perspective alphabetical is better than the most popular ones at the top, or the other way around. Can we get somebody from UX weigh in on this?

Comment 20

6 years ago
Jaclyn, can you weigh in here?
(Reporter)

Comment 21

6 years ago
alphabetical is more predictable for the user I suppose, but I'm no UX expert..

Comment 22

6 years ago
Given that we're on a tight schedule, let's go with alphabetical for now. We can revisit later if need be.
Blocks: 766209
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

6 years ago
CAn we see a staged version?
(Assignee)

Comment 24

6 years ago
(In reply to Jaclyn Fu from comment #23)
> CAn we see a staged version?

http://www-dev.allizom.org/b/en-US/firefox/mobile/platforms/

Comment 25

6 years ago
Hey Steven. Can we implement the menu that Sean indicated in his original mockups? http://cl.ly/2w1v0w3M3I0L0T1J1A0e/o
(Reporter)

Comment 26

6 years ago
Can we we combine Sony Ericcson and Sony into just "Sony"?
(Reporter)

Comment 27

6 years ago
Sorry! please disregard that last comment leave as is please
(Reporter)

Comment 28

6 years ago
Also, where is the admin tool going to be hosted/live?
(Assignee)

Comment 29

6 years ago
(In reply to John Slater from comment #25)
> Hey Steven. Can we implement the menu that Sean indicated in his original
> mockups? http://cl.ly/2w1v0w3M3I0L0T1J1A0e/o

craigcook is working on the mobile menu - this will apply to all pages when it's ready.

(In reply to Jaclyn Fu from comment #28)
> Also, where is the admin tool going to be hosted/live?

For this round of updates, we don't have an graphical admin tool. Instead, the list on the page is built from a comma-separated text file.

Comment 30

6 years ago
(In reply to Steven Garrity from comment #29)
> craigcook is working on the mobile menu - this will apply to all pages when
> it's ready.

awesome, thanks.
(Reporter)

Comment 31

6 years ago
Thanks, so where should QA go when we want to update the list of devices? 


> For this round of updates, we don't have an graphical admin tool. Instead,
> the list on the page is built from a comma-separated text file.
(Reporter)

Comment 32

6 years ago
Under the download button at the top, instead of systems and languages it should be "supported devices" that links to mozilla.org/mobile/platforms

And for "what's new" under the download button it should link to "mozilla.org/mobile/notes"

Thanks!
Hi (again)

Same comments as on Features

1.  home instead of FFX
2.  calling out Google play / external site on the download button

3. also, font in OEM list seems really large.  is it the same as other fonts on page?

thanks

Comment 34

6 years ago
Thanks Pete. Some thoughts inline-

> Same comments as on Features
> 
> 1.  home instead of FFX
> 2.  calling out Google play / external site on the download button

Good thoughts...more detailed responses from me in bug 763650.
 
> 3. also, font in OEM list seems really large.  is it the same as other fonts
> on page?

It's consistent with our site style - I think it's ok.
(Assignee)

Comment 35

6 years ago
The links under the download buttons are fixed - I think the rest of the issues have been addressed in comments.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.