crash in nsThread::ProcessNextEvent

RESOLVED WORKSFORME

Status

Thunderbird
General
--
critical
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: wsmwk, Unassigned)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [startupcrash], crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-c402db77-1f92-4db4-a806-e42d32120410 .
============================================================= 
0		@0x215fec8	
1	xul.dll	nsThread::ProcessNextEvent	xpcom/threads/nsThread.cpp:660
2	xul.dll	NS_ProcessNextEvent_P	objdir-tb/mozilla/xpcom/build/nsThreadUtils.cpp:245
3	xul.dll	nsThread::ThreadFunc	xpcom/threads/nsThread.cpp:292
4	nspr4.dll	_PR_NativeRunThread	nsprpub/pr/src/threads/combined/pruthr.c:426 

~85 rank for thunderbird 12.0.1
no correlations given
all crashes cited  here have email addresses
bp-1138a9f0-9198-43ec-b0ff-90acc2120309
bp-68aa6850-6677-4348-abcb-b60552120223
bp-75fbe555-6115-4cf4-aeb4-451032120420

bug 598769 for firefox implicates McAffee
(Reporter)

Comment 1

6 years ago
 nsThread::ProcessNextEvent for linux

nsRefPtr<nsCanvasPatternAzure>::~nsRefPtr<nsCanvasPatternAzure>() | nsThread::ProcessNextEvent(int, int*)
Crash Signature: [@ nsThread::ProcessNextEvent(bool, bool*)] → [@ nsThread::ProcessNextEvent(bool, bool*)] [@ nsThread::ProcessNextEvent ]

Comment 2

6 years ago
I would guess the event is garbage - this is unlikely to be Thunderbird specific.
(Reporter)

Comment 3

6 years ago
1/4 are startup crashes.
I'm seeing this on a unagi, when closing a packaged app using window.close() after updating.

https://crash-stats.mozilla.com/report/index/b1daa088-edb8-4da1-9632-e4e042130208

Comment 7

4 years ago
Totally random non-reproducible crash:
https://crash-stats.mozilla.com/report/index/50d3f52c-dcc9-4abe-b1da-61d8e2140511

Updated

3 years ago
Crash Signature: [@ nsThread::ProcessNextEvent(bool, bool*)] [@ nsThread::ProcessNextEvent ] → [@ nsThread::ProcessNextEvent(bool, bool*)] [@ nsThread::ProcessNextEvent ] [@ nsThread::ProcessNextEvent]
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year).
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
Ups, my bad and due to ( bug #1348631 ) looks like there are sill crashes, so reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

a year ago
2-3 crashes per month[1] is a far cry from previous comments. Perhaps it morphed to something else. But we don't have any reporters cited in this bug, so nothing further we can check on.  WFM is appropriate.

[1] https://crash-stats.mozilla.com/signature/?signature=nsThread%3A%3AProcessNextEvent&date=%3E%3D2017-02-27T11%3A48%3A35.000Z&date=%3C2017-03-27T11%3A48%3A35.000Z&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_columns=install_time&_sort=-date&page=1
Status: REOPENED → RESOLVED
Crash Signature: [@ nsThread::ProcessNextEvent(bool, bool*)] [@ nsThread::ProcessNextEvent ] [@ nsThread::ProcessNextEvent] → [@ nsThread::ProcessNextEvent(bool, bool*)] [@ nsThread::ProcessNextEvent]
Last Resolved: a year agoa year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.