Sometimes videos/screenshots 404 on the edit listing page

VERIFIED FIXED in 2012-08-30

Status

VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: krupa.mozbugs, Assigned: andy+bugzilla)

Tracking

2012-08-30
Points:
---

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Upload an app. 
2. In Step 3, upload a video and then a screenshot
3. Complete app submission.
4. Go to /edit page for this app

reproducible? Sometimes

actual behavior:
The video thumbnail never loads and the image 404s

[13:03:11.763] GET https://marketplace-dev-cdn.allizom.org/img/uploads/previews/thumbs/69/69529.png?modified=1336073621&1336075391761 [HTTP/1.1 404 Not Found 22ms]
(Reporter)

Comment 1

7 years ago
May  3 12:33:41 celery1.dev.addons.phx1.mozilla.com: [][] z.devhub.task:INFO [1@None] Encoding video 69529 :/data/www/addons-dev.allizom.org/zamboni/lib/video/tasks.py:26
1:05 PM
May  3 12:33:42 celery1.dev.addons.phx1.mozilla.com: [][] z.devhub.task:INFO Error making thumbnail for 69529 :/data/www/addons-dev.allizom.org/zamboni/lib/video/tasks.py:57
(Reporter)

Comment 2

7 years ago
http://jason.pastebin.mozilla.org/1614928
Summary: Sometimes screenshots 404 on the edit listing page → Sometimes videos/screenshots 404 on the edit listing page
(Reporter)

Comment 3

7 years ago
May 22 14:38:07 celery1.dev.addons.phx1.mozilla.com: [<anon>][None] z.addons:ERROR Failed to open saved manifest u'http://whatever1234.testmanifest.com/manifest.webapp' for webapp 370269, 'NoneType' object has no attribute 'file_path'. :/data/www/addons-dev.allizom.org/zamboni/mkt/webapps/models.py:222
May 22 14:38:07 celery1.dev.addons.phx1.mozilla.com: [][] z.celery:ERROR  Celery TASK exception: AttributeError: 'NoneType' object has no attribute 'file_path' :/data/www/addons-dev.allizom.org/zamboni/vendor/src/nuggets/celeryutils.py:46#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/nuggets/celeryutils.py", line 35, in wrapped#012    return fun(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 139, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 131, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/mkt/developers/tasks.py", line 330, in fetch_icon#012    manifest = webapp.get_manifest_json()#012  File "/data/www/addons-dev.allizom.org/zamboni/mkt/webapps/models.py", line 218, in get_manifest_json#012    with open(self.get_latest_file().file_path, 'r') as mf:#012AttributeError: 'NoneType' object has no attribute 'file_path'
May 22 14:38:07 celery1.dev.addons.phx1.mozilla.com: [][] z.celery:ERROR Celery TASK exception: AttributeError: 'NoneType' object has no attribute 'file_path' :/data/www/addons-dev.allizom.org/zamboni/vendor/src/nuggets/celeryutils.py:46#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/nuggets/celeryutils.py", line 35, in wrapped#012    return fun(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 139, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 131, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/mkt/developers/tasks.py", line 330, in fetch_icon#012    manifest = webapp.get_manifest_json()#012  File "/data/www/addons-dev.allizom.org/zamboni/mkt/webapps/models.py", line 218, in get_manifest_json#012    with open(self.get_latest_file().file_path, 'r') as mf:#012AttributeError: 'NoneType' object has no attribute 'file_path'
May 22 14:38:07 celery1.dev.addons.phx1.mozilla.com: [][] celery:ERROR Task mkt.developers.tasks.fetch_icon[b3cf95b0-10fc-468c-9d0d-1703f7717a84] raised exception: AttributeError("'NoneType' object has no attribute 'file_path'",) :/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/worker/job.py:393#012Traceback (most recent call last):#012  File "/data/www/addons-dev.allizom.org/zamboni/vendor/lib/python/celery/execute/trace.py", line 153, in trace_task#012    R = retval = task(*args, **kwargs)#012  File "/data/www/addons-dev.allizom.org/zamboni/vendor/src/nuggets/celeryutils.py", line 35, in wrapped#012    return fun(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 139, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/apps/amo/decorators.py", line 131, in wrapper#012    return f(*args, **kw)#012  File "/data/www/addons-dev.allizom.org/zamboni/mkt/developers/tasks.py", line 330, in fetch_icon#012    manifest = webapp.get_manifest_json()#012  File "/data/www/addons-dev.allizom.org/zamboni/mkt/webapps/models.py", line 218, in get_manifest_json#012    with open(self.get_latest_file().file_path, 'r') as mf:#012AttributeError: 'NoneType' object has no attribute 'file_path'
Seems related to bug 756285.
Component: Developer Pages → Developer Pages
Product: addons.mozilla.org → Marketplace
QA Contact: developers → developer-pages
Version: unspecified → 1.0
Yes is duplicated of bug 756285.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Whiteboard: [testday-20120628]
Duplicate of bug: 756285
(Reporter)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [testday-20120628]
(Reporter)

Updated

6 years ago
Status: REOPENED → NEW
-> andym to investigate
Assignee: nobody → amckay
Target Milestone: --- → 2012-08-30
(Assignee)

Comment 7

6 years ago
The icon errors are fixed, the video encoding is fixed.

Let's assume that it's ok, reopen if not.
Status: NEW → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
I haven't see this in a while. Marking as verified fixed at https://marketplace-dev.allizom.org/developers/submit/app/details/test-app-cow277678
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.