Last Comment Bug 751694 - Smoke-test a 32-bit build of Firefox made on one of our Win64 builders
: Smoke-test a 32-bit build of Firefox made on one of our Win64 builders
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Anthony Hughes (:ashughes) [GFX][QA][Mentor]
:
Mentors:
Depends on:
Blocks: PGOSilverBullet
  Show dependency treegraph
 
Reported: 2012-05-03 13:33 PDT by :Ehsan Akhgari
Modified: 2012-05-25 12:04 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add-on Update results (3.43 KB, text/plain)
2012-05-23 12:52 PDT, Anthony Hughes (:ashughes) [GFX][QA][Mentor]
no flags Details

Description :Ehsan Akhgari 2012-05-03 13:33:25 PDT
I have produced a 32-bit build of Firefox on one of our Win64 builders.  I'm filing this bug in order to get that build smoke-tested by QA.  Not sure who to CC from QA about this.

The build is available at <http://people.mozilla.org/~eakhgari/win32onwin64/firefox-15.0a1.en-US.win32.zip>.
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2012-05-03 16:39:26 PDT
I ran this build on my old/dirty profile, and had no problems.  Didn't see a bit of difference in performance from what I usually see.

Will let QA rip into it for a hard compare.

Ran for just over 3 hrs or so.
Comment 2 JP Rosevear [:jpr] 2012-05-03 17:12:23 PDT
Anthony, I believe you are going to QA this build?
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-03 17:48:55 PDT
(In reply to JP Rosevear [:jpr] from comment #2)
> Anthony, I believe you are going to QA this build?

Yup. It's passed the end of my day though. I'll get some of our QA people in eastern Europe running it over night and will check it myself tomorrow morning.
Comment 4 Armen Zambrano [:armenzg] - Engineering productivity 2012-05-04 09:02:07 PDT
I can run unit tests for this build on staging for Windows 7 and Windows XP if wanted to.
Comment 5 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-04 09:37:04 PDT
Results of our European testers are in:
 * Plug-ins generally fail to work
 * General performance seems to degrade over time

https://etherpad.mozilla.org/mozqa-win32onwin64-nightly

Please read the etherpad and follow up in this bug with any questions or test requests.
Comment 6 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-04 09:44:07 PDT
Note, the issues with plugins could very well just be bug 751641 and not necessarily related to this win32 build.
Comment 7 :Ehsan Akhgari 2012-05-04 10:17:23 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #6)
> Note, the issues with plugins could very well just be bug 751641 and not
> necessarily related to this win32 build.

Ah, right, that was unfortunate.  Do you want me to re-request access to a builder and do another build with that fix?
Comment 8 Armen Zambrano [:armenzg] - Engineering productivity 2012-05-04 10:21:23 PDT
(In reply to Ehsan Akhgari [:ehsan] from comment #7)
> (In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #6)
> > Note, the issues with plugins could very well just be bug 751641 and not
> > necessarily related to this win32 build.
> 
> Ah, right, that was unfortunate.  Do you want me to re-request access to a
> builder and do another build with that fix?

The same machine is still available for you. I have not a had a chance to re-purpose it.
Comment 9 :Ehsan Akhgari 2012-05-04 10:25:05 PDT
(In reply to Armen Zambrano G. [:armenzg] - Release Engineer from comment #8)
> (In reply to Ehsan Akhgari [:ehsan] from comment #7)
> > (In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #6)
> > > Note, the issues with plugins could very well just be bug 751641 and not
> > > necessarily related to this win32 build.
> > 
> > Ah, right, that was unfortunate.  Do you want me to re-request access to a
> > builder and do another build with that fix?
> 
> The same machine is still available for you. I have not a had a chance to
> re-purpose it.

OK, thanks.  I'll do another build with that fix then.
Comment 10 :Ehsan Akhgari 2012-05-04 10:33:27 PDT
I'm doing a new build based on revision eeba341b7e45 from mozilla-inbound.
Comment 11 :Ehsan Akhgari 2012-05-04 15:34:43 PDT
New build available at <http://people.mozilla.org/~eakhgari/win32onwin64-2/firefox-15.0a1.en-US.win32.zip>.  I also packages the tests and symbols so that we can use this build on our test machines.  They all reside in the same directory.  Chris, do you know what I should do?  Thanks!
Comment 12 Chris AtLee [:catlee] 2012-05-05 06:23:55 PDT
I kicked these off with some buildbot hackery:
https://build.mozilla.org/buildapi/self-serve/try/rev/eeba341b7e45

the talos jobs failed because they're trying to look for http://hg.mozilla.org/mozilla-central/raw-file/dcbe18b7cb47/testing/talos/talos_from_code.py. I haven't tracked down exactly why that's happening...there's a talos.json file in the .zip somewhere that points to this file. also, the build thinks it was built from mozilla-central, not inbound.
Comment 13 Chris AtLee [:catlee] 2012-05-05 06:26:44 PDT
not sure if these will be visible on tbpl or not, but the logs shoudl show up here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-eeba341b7e45/try-win32/
Comment 14 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-07 13:51:55 PDT
(In reply to Chris AtLee [:catlee] from comment #13)
> not sure if these will be visible on tbpl or not, but the logs shoudl show
> up here:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.
> com-eeba341b7e45/try-win32/

Sorry, I missed this over the weekend. I'll get our Romanian testers to run this build tonight.
Comment 15 :Ehsan Akhgari 2012-05-07 15:30:26 PDT
So there's a consistent failure in test_aboutmemory.xul on both XP (http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-eeba341b7e45/try-win32/try_xp_test-mochitest-other-bm15-tests1-windows-build3499.txt.gz) and Win7 (http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-eeba341b7e45/try-win32/try_win7_test-mochitest-other-bm16-tests1-windows-build3872.txt.gz).

The expected and actual values in that test differ like this:

--- 1	2012-05-07 18:22:34.000000000 -0400
+++ 2	2012-05-07 18:22:30.000000000 -0400
@@ -74,7 +74,6 @@
  other3
  other4
  other5
- other6
 This indicates a defect in one or more memory reporters.  The invalid values are highlighted.
 
 Explicit Allocations
@@ -94,7 +93,7 @@
       -333 ── other3 [?!]
       -444 ── other4 [?!]
     -5.55% ── other5 [?!]
-   666.66% ── other6 [?!]
+   666.66% ── other6
 
 5th Process
 

Nick, can you please take a look and see if you can think of why this could be happening?  See comment 11 in case you need the built itself.
Comment 16 Nicholas Nethercote [:njn] 2012-05-07 16:34:55 PDT
See https://bugzilla.mozilla.org/show_bug.cgi?id=751509#c3 -- jlebar landed a change that broke this test, then backed the change out, and relanded with a test fix.  Did you unluckily choose the first, test-breaking revision (c1243d1fb401) for your testing?
Comment 17 :Ehsan Akhgari 2012-05-07 20:26:27 PDT
(In reply to Nicholas Nethercote [:njn] from comment #16)
> See https://bugzilla.mozilla.org/show_bug.cgi?id=751509#c3 -- jlebar landed
> a change that broke this test, then backed the change out, and relanded with
> a test fix.  Did you unluckily choose the first, test-breaking revision
> (c1243d1fb401) for your testing?

Indeed that is what happened!  Thanks Nick!

To the rest of people on this bug: this was a false red flag, and you can ignore comment 15.
Comment 18 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-08 09:24:52 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #14)
> (In reply to Chris AtLee [:catlee] from comment #13)
> > not sure if these will be visible on tbpl or not, but the logs shoudl show
> > up here:
> > http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.
> > com-eeba341b7e45/try-win32/
> 
> Sorry, I missed this over the weekend. I'll get our Romanian testers to run
> this build tonight.

The build seems to have disappeared so we weren't able to test it. Where can I get a new build from?
Comment 19 Chris AtLee [:catlee] 2012-05-08 09:58:00 PDT
The build is still located at http://people.mozilla.org/~eakhgari/win32onwin64/firefox-15.0a1.en-US.win32.zip
Comment 20 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-08 10:54:27 PDT
(In reply to Chris AtLee [:catlee] from comment #19)
> The build is still located at
> http://people.mozilla.org/~eakhgari/win32onwin64/firefox-15.0a1.en-US.win32.
> zip

Oops...thanks. Sorry for the confusion. I'll make sure this is tested by tomorrow.
Comment 21 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-05-22 16:07:20 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #20)
> (In reply to Chris AtLee [:catlee] from comment #19)
> > The build is still located at
> > http://people.mozilla.org/~eakhgari/win32onwin64/firefox-15.0a1.en-US.win32.
> > zip
> 
> Oops...thanks. Sorry for the confusion. I'll make sure this is tested by
> tomorrow.

ping?
Comment 22 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-05-22 16:28:42 PDT
per irc:

Most of this testing was already done in https://bugzilla.mozilla.org/show_bug.cgi?id=753132#c10.

Still to do:
* some update testing 
* some binary compat/binary addon testing
Comment 23 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-22 16:34:45 PDT
Sorry for the confusion, the update/binary testing will be done overnight.
Comment 24 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-05-23 12:52:55 PDT
Created attachment 626561 [details]
Add-on Update results

Here are the results of the add-on update testing. The short version is that no issues were found.
Comment 25 John O'Duinn [:joduinn] (please use "needinfo?" flag) 2012-05-25 12:02:13 PDT
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #24)
> Created attachment 626561 [details]
> Add-on Update results
> 
> Here are the results of the add-on update testing. The short version is that
> no issues were found.

Cool to see this and also https://bugzilla.mozilla.org/show_bug.cgi?id=753132#c10. Anything left to do or can we close this as FIXED_AND_HAPPY ?
Comment 26 :Ehsan Akhgari 2012-05-25 12:04:54 PDT
People have been using these builds for some time now!

Note You need to log in before you can comment on or make changes to this bug.