Last Comment Bug 751729 - File dialogs don't open when SeaMonkey and Firefox are run with Visual Themes disabled in Windows 7
: File dialogs don't open when SeaMonkey and Firefox are run with Visual Themes...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: 12 Branch
: x86_64 Windows 7
: -- major (vote)
: mozilla16
Assigned To: Brian R. Bondy [:bbondy]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 15:23 PDT by entonio
Modified: 2012-07-05 22:45 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1. (1.57 KB, patch)
2012-07-03 04:15 PDT, Brian R. Bondy [:bbondy]
no flags Details | Diff | Review
Patch v2. (5.74 KB, patch)
2012-07-03 07:19 PDT, Brian R. Bondy [:bbondy]
jmathies: review+
Details | Diff | Review

Description entonio 2012-05-03 15:23:23 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20120429 Firefox/12.0 SeaMonkey/2.9.1
Build ID: 20120429011004

Steps to reproduce:

Try to open a file or save a file or attachment. All such dialogs are affected, in the browser and in the mail client, including the 'Save All' for attachments. Saving without dialog, to a default location, works.
The bug has happened at least since SM 2.8 on Windows 7 x64. It doesn't seem to happen on Mac OS X 10.6.


Actual results:

The dialog doesn't open. Nothing happens.


Expected results:

The dialog should open.
Comment 1 entonio 2012-05-03 15:26:16 PDT
Tried using a new profile, same result.
Tried using safe mode, same result.
Tried disabling all extensions, same result.
Tried everything together, same result.
This had never happened prior to the update. Before the update I was running some 2.x version, I can't guarantee it was 2.7, but it must have been close.
Comment 2 entonio 2012-05-03 15:28:43 PDT
OBS: This happened simultaneously in my work and home computer, with the 2.8 update. Both are Windows 7 x64.
Comment 3 Philip Chee 2012-05-04 09:25:14 PDT
This probably won't help but try downloading the SeaMonkey 2.9.1 installer from:
<http://www.seamonkey-project.org/releases/>
and then reinstalling.
Comment 4 entonio 2012-05-04 09:58:31 PDT
Well! I tried using the 2.9.1 installer in my home computer (which still had 2.8) and nothing changed (thanks anyway). But that prompted me to look at the shortcut I was using, and in Properties\Comptibility I had, in times, selected 'Disable Visual Themes'. I tried unchecking that, and voila, the dialogs work if it is unchecked. Of course, they used to work before, with it checked.
So... whatever the cause of this behaviour is, it may be traced to something having to do with the 'Compatibility - Disable Visual Themes' thing. It's a per-executable setting, iiuc.
Comment 5 Philip Chee 2012-05-04 22:42:21 PDT
Are you using a third party Windows 7 theme? Try going to Control Panel->Personalization and choose one of the Windows7 themes that came with the system.
Comment 6 Philip Chee 2012-05-04 22:51:14 PDT
Confirm also happens with Firefox 12.
Comment 7 entonio 2012-05-06 16:40:34 PDT
My theme is the normal Aero one.
I've tried disabling the theme altogether and got the same result: dialogs work if and only if the compatibility setting is unchecked.
This behaviour happens from at least 2.8 on.
Comment 8 Philip Chee 2012-07-02 04:42:47 PDT
Kyle Huey suggests I CC :bbondy and :jimm
Comment 9 Brian R. Bondy [:bbondy] 2012-07-02 20:13:47 PDT
I'll take a look tomorrow.
Comment 10 Brian R. Bondy [:bbondy] 2012-07-03 04:15:25 PDT
Created attachment 638648 [details] [diff] [review]
Patch v1.
Comment 11 Jim Mathies [:jimm] 2012-07-03 04:53:15 PDT
Will canceling the dialog give us a false return here?

http://mxr.mozilla.org/mozilla-central/source/widget/windows/nsFilePicker.cpp#598

Maybe we should fall through only when CoCreateInstance fails.
Comment 12 Brian R. Bondy [:bbondy] 2012-07-03 07:19:05 PDT
Created attachment 638708 [details] [diff] [review]
Patch v2.

Thanks for the review, good catch!
Comment 14 Ryan VanderMeulen [:RyanVM] 2012-07-05 17:19:53 PDT
https://hg.mozilla.org/mozilla-central/rev/9015f41f5e4e
Comment 15 Philip Chee 2012-07-05 22:45:13 PDT
Thank you Brian!

Note You need to log in before you can comment on or make changes to this bug.