Firefox 9 allows interaction during Javascript execution, but Firefox 11+ does not

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: Evgueni Naverniouk, Unassigned)

Tracking

14 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120502 Firefox/14.0a2
Build ID: 20120502042005

Steps to reproduce:

In Firefox 9, I open a website with heavy javascript (or create a long loop in Firebug) and which the Javascript is executing I'm able to open new Firefox tabs and windows.

In Firefox 11, 12 and 14 (haven't tested 10), when I do the same thing - I'm unable to open new tabs or windows, or even go File > Open File... The browser is completely locked up until the javascript done, or killed.


Actual results:

See above


Expected results:

See above

Comment 1

6 years ago
Do you have a testcase of or URL that demonstrates the issue?
Keywords: testcase-wanted
(Reporter)

Comment 2

6 years ago
The test can I used is:

1. Open a new Firebug tab. Open Firebug's console and enter something like this:

for (var i = 0; i < 10000; i++) {
console.log(document.getElementsByTagName('div'));
}

2. Then immediately try to press the "New Tab" button, or File > New Tab, or press Ctrl+T.
Hello Evgueni,

with the test case you gave us, I made some test on FF 34 and also on nightly 37.
I'm able to open new pages in same time the script is running, but it is slow :-)

can you confirm this also from your site?
Flags: needinfo?(globexdesigns)
(Reporter)

Comment 4

4 years ago
Confirmed. Seems to be working but slow in Firefox 34. I guess you can close this.
Flags: needinfo?(globexdesigns)
thank you for the feedback.

closed!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Keywords: testcase-wanted
You need to log in before you can comment on or make changes to this bug.