Last Comment Bug 751796 - [AccessFu] disable() does not shut down event listeners
: [AccessFu] disable() does not shut down event listeners
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: mozilla15
Assigned To: Eitan Isaacson [:eeejay]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-03 19:35 PDT by Eitan Isaacson [:eeejay]
Modified: 2012-05-07 17:58 PDT (History)
2 users (show)
ryanvm: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
shut down AccessFu properly on disable(). (2.21 KB, patch)
2012-05-03 19:36 PDT, Eitan Isaacson [:eeejay]
dbolter: review+
Details | Diff | Splinter Review

Description Eitan Isaacson [:eeejay] 2012-05-03 19:35:03 PDT
event callbacks keep getting called. this included key presses, a11y events, and other DOM events we add listeners to when first calling enable().
Comment 1 Eitan Isaacson [:eeejay] 2012-05-03 19:36:54 PDT
Created attachment 620933 [details] [diff] [review]
shut down AccessFu properly on disable().

I was just being really sloppy in the detach() and enable methods..
Comment 2 David Bolter [:davidb] ***PTO until 29th*** 2012-05-03 19:52:38 PDT
Comment on attachment 620933 [details] [diff] [review]
shut down AccessFu properly on disable().

OK r=me. I had to refresh myself (via nsIDOMEventTarget.idl comments). Basically you have to add the usecapture arg since you add the event listeners with capture true right? Also the (haha!) s/addObserver/removeObserver should make things nicer :)
Comment 3 Eitan Isaacson [:eeejay] 2012-05-03 19:53:58 PDT
yes. you need the usecapture flag. thanks!
Comment 4 Eitan Isaacson [:eeejay] 2012-05-07 09:55:11 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/b58c6e5156d7
Comment 5 Ryan VanderMeulen [:RyanVM] 2012-05-07 17:58:40 PDT
http://hg.mozilla.org/mozilla-central/rev/b58c6e5156d7

Should this have a test?

Note You need to log in before you can comment on or make changes to this bug.