Valid LinkedIn URL for reps.mozilla.org was flagged invalid

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Ren² Gabás, Assigned: giorgos)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 620954 [details]
Capture.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:14.0) Gecko/20120502 Firefox/14.0a2
Build ID: 20120502042005

Steps to reproduce:

Typed in a Valid LinkedIn profile URL
http://ph.linkedin.com/in/renrengabas


Actual results:

URL was not recognized as a valid LinkedIn URL


Expected results:

LinkedIn URL can be saved into the Mozilla Rep profile
(Assignee)

Comment 1

6 years ago
Hey Ren,

Thanks for reporting this. It's actually the "ph" part that's messing with the regex. If you try "www" instead it will work.

I'm marking this as new though since it's confusing for many reps.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

6 years ago
Assignee: nobody → giorgos
Status: NEW → ASSIGNED
(Reporter)

Comment 2

6 years ago
Thanks, Giorgos. Yeah, I didn't know that the PH can simply be replaced by WWW. I'll go put it on my profile now.

Comment 3

6 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/8272a9b0a8b082192eeb51d2b872470527e91bbf
Permit *.facebook.com and *.linkedin.com urls. Fix bug 751807.

https://github.com/mozilla/remo/commit/e2afdf5c2be5c04d84b0317db8bf9242573fbfc2
Merge pull request #158 from glogiotatidis/751807-valid-linkedin-url

Permit *.facebook.com and *.linkedin.com urls. Fix bug 751807.

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 4

6 years ago
Verified

http://foo.linkedin.com/foo

http://foo.facebook.com/foo
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.