If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Commit Access (level 1a, hg, scm_l10n) for Muhammad Syafiq Mazli

RESOLVED FIXED

Status

mozilla.org
Repository Account Requests
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Muhammad Syafiq Mazli, Assigned: dumitru)

Tracking

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 620978 [details]
syafiqmazli-ssh.pub

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

sign off for Firefox ms to SVN
(Reporter)

Comment 1

6 years ago
I already email photograph proof signed Committer's Agreement Mozilla Foundation to email, mcclure@mozilla.com

Thanks,

@syafiqmazli

Updated

6 years ago
Assignee: nobody → desktop-support
Component: Release Engineering: Automation (General) → Server Operations: Account Requests
QA Contact: catlee → tfairfield

Updated

6 years ago
Assignee: desktop-support → mozillamarcia.knous
Component: Server Operations: Account Requests → Repository Account Requests
QA Contact: tfairfield → repo-acct-req

Comment 2

6 years ago
Muhammad, did you ask for a level 3 account on purpose or are you just looking for the permissions required to land contributions to ms? Which would be a level 1a, see http://www.mozilla.org/hacking/commit-access-policy/
(Reporter)

Comment 3

6 years ago
Pike, 

i don't know which level i should apply. If level 1a is fine to me also. 

Thanks.

@syafiqmazli
Summary: Commit Access (Level 3) for Muhammad Syafiq Mazli → Commit Access (Level 1a) for Muhammad Syafiq Mazli
Adding Erica to confirm the form.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

5 years ago
I have received Muhammad's Committer's Agreement.
Muhammad: I think the only piece left here is someone to vouch for our access to ms.
(Reporter)

Comment 7

5 years ago
Marcia, who will vouch the access?

Comment 8

5 years ago
I'll vouch for Syafiq access
Thanks Arky. I can move over to server-ops for Level 1a access but the only other question is whether he needs to be added to the @localizers group as well.

Comment 10

5 years ago
No idea what @localizers group is, Pike would be able to answer that.
Assuming comment 0 is correct, SVN access to the "ms" locale require only svn+@localizers membership+password reset (no Hg/SSH access necessary).

Over to server-ops for that!
Assignee: mozillamarcia.knous → server-ops
Summary: Commit Access (Level 1a) for Muhammad Syafiq Mazli → Commit Access (svn/@localizers) for Muhammad Syafiq Mazli

Updated

5 years ago
Attachment #620978 - Attachment mime type: application/octet-stream → text/plain

Comment 12

5 years ago
The original request was wrong (see the summary change along comment 3), so this should be a hg level 1a with scm_l10n account. Please also add @Localizers and send out a password notification.
Summary: Commit Access (svn/@localizers) for Muhammad Syafiq Mazli → Commit Access (level 1a, hg, scm_l10n) for Muhammad Syafiq Mazli
(Assignee)

Updated

5 years ago
Assignee: server-ops → dgherman
(Assignee)

Comment 13

5 years ago
HG scm_l10n enabled
SVN enabled and added to @localizers.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

5 years ago
Hi, i have problem when to run hg push command. As below

syafiqmazli@syafiqmazli-PC ~/Documents/firefoxbm/ms $ hg push
pushing to ssh://hg.mozilla.org/releases/l10n/mozilla-aurora/ms
remote: Permission denied (publickey,keyboard-interactive).
abort: no suitable response from remote hg

Anyone could help me?
(Assignee)

Comment 15

5 years ago
Please take a look here first and follow these instructions:

https://developer.mozilla.org/en/Mercurial_FAQ

Comment 16

5 years ago
Syafiq, Did the information help. Please let us know.
(Reporter)

Comment 17

5 years ago
I think i stuck on ssh key configuration. Should i use same key as attached on this bug or i able to create new ssh key?
(Assignee)

Comment 18

5 years ago
Up to you.
If you have a new SSH key, I can replace it. Just send me the public part.
(Reporter)

Comment 19

5 years ago
Created attachment 640489 [details]
new public key

Hi Dumitru,

I attached new public key for new adding replace. As per attached. Thanks
(Assignee)

Comment 20

5 years ago
Key replaced.
(Reporter)

Comment 21

5 years ago
Thanks Dumitru. Now is working.

Comment 22

5 years ago
Syafiq, did you manage to recover your pass phrase?
(Reporter)

Comment 23

5 years ago
@Arky, i think i have to generate new key because i forgot my key's pass phrase. I will update this bug with new key and please replace for new key to my access.

@syafiq
(Reporter)

Comment 24

5 years ago
Created attachment 649002 [details]
Latest public key 04082012

Hi,

Could anyone replace with my new public key as per attached on this bug.

Thanks,

@syafiqmazli
You should generally file new bug requests for followup changes, comments in resolved bugs are likely to be missed. You can file a mozilla.org::Server Operations bug to get your key updated, or just poke someone in #it on IRC.
You need to log in before you can comment on or make changes to this bug.