Exception when running mozmill-restart without specifying a manifest file or tests

RESOLVED WONTFIX

Status

Testing Graveyard
Mozmill
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: davehunt, Unassigned)

Tracking

Details

(Whiteboard: [mozmill-1.5.13-][mozmill-1.5-only])

We have a manifest file that has every entry disabled. This acts as though no manifest was specified at all, and
(Reporter)

Comment 1

6 years ago
Apologies for somehow hitting submit too early on this bug. Please ignore comment 0.

If you run mozmill-restart without specifying any tests or manifest file the following is thrown:

$ mozmill-restart -b /Applications/FirefoxNightly.app/
Traceback (most recent call last):
  File "/Users/dhunt/.virtualenvs/mozmill-release/bin/mozmill-restart", line 8, in <module>
    load_entry_point('mozmill==1.5.11', 'console_scripts', 'mozmill-restart')()
  File "/Users/dhunt/.virtualenvs/mozmill-release/lib/python2.7/site-packages/mozmill/__init__.py", line 857, in restart_cli
    RestartCLI().run()
  File "/Users/dhunt/.virtualenvs/mozmill-release/lib/python2.7/site-packages/mozmill/__init__.py", line 826, in run
    runner.wait()
  File "/Users/dhunt/.virtualenvs/mozmill-release/lib/python2.7/site-packages/mozrunner/__init__.py", line 512, in wait
    self.process_handler.wait(timeout=timeout)
AttributeError: 'NoneType' object has no attribute 'wait'

Due to bug 751847 we are seeing this when a manifest with every entry is disabled.
Summary: Exception when running mozmill-restart without a manifest file with all entries disabled → Exception when running mozmill-restart without specifying a manifest file or tests
I can see this too. What about Mozmill 2.0?
Whiteboard: [mozmill-1.5.12?]
(Reporter)

Comment 3

6 years ago
Unfortunately I'm unable to test this with Mozmill 2 because of bug 751348.
Depends on: 751348
Whiteboard: [mozmill-1.5.12?] → [mozmill-1.5.13?]

Comment 4

6 years ago
Minusing on 1.5.x but leaving open to be certain that this *doesn't* happen on 2.0. once we check 2.0 we will know how to resolve this bug.
Whiteboard: [mozmill-1.5.13?] → [mozmill-1.5.13-]
(Reporter)

Comment 5

6 years ago
Bug 751348 is now fixed, but I've now discovered bug 753190.
Depends on: 753190

Updated

6 years ago
Whiteboard: [mozmill-1.5.13-] → [mozmill-1.5.13-][good first bug]
(In reply to Dave Hunt (:davehunt) from comment #5)
> Bug 751348 is now fixed, but I've now discovered bug 753190.

Both bugs are fixed now. Dave, would you mind re-testing?
(Reporter)

Comment 7

6 years ago
This issue still exists in Mozmill 1.5.18. The blocking bugs are as you note fixed, and only affected Mozmill 2.0.
I know that 1.5.18 is affected. My question on comment 2 hasn't been answered yet if Mozmill 2.0 is also affected. If not we will most likely wontfixing this bug.
(Reporter)

Comment 9

6 years ago
I can confirm that Mozmill 2.0 is not affected.
Thanks Dave. So we can go ahead and wontfix it.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Whiteboard: [mozmill-1.5.13-][good first bug] → [mozmill-1.5.13-][mozmill-1.5-only]
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.