Last Comment Bug 751871 - After upgrade refuses to start - crashes with "Terminate called without an active exception" in terminal.
: After upgrade refuses to start - crashes with "Terminate called without an ac...
Status: VERIFIED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 15 Branch
: All Linux
: -- critical (vote)
: Thunderbird 15.0
Assigned To: Mark Banner (:standard8)
:
:
Mentors:
: 752140 (view as bug list)
Depends on:
Blocks: 736564
  Show dependency treegraph
 
Reported: 2012-05-04 06:07 PDT by AndrzejL
Modified: 2012-07-30 13:27 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description AndrzejL 2012-05-04 06:07:07 PDT
User Agent: Mozilla/5.0 (X11; Linux i686; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120503030512

Steps to reproduce:

Installed Thunderbird Daily using this method:

http://andrzejl.no-ip.org:10101/wordpress/2012/04/25/testing-mozilla-thunderbird-central-daily-15-safely-on-pclinuxos-2012-x/

Worked flawlessly as always till today.


Actual results:

I have noticed that there was a update ready to be applied in the Help > About Daily section and so I have applied it. Right after Thunderbird "restarted" itself it crashed and wanted to report error - so I did that. I thought that maybe a full reboot will do it - nope. Application crashes in safe mode too.


Expected results:

Well I really love this part... Uhm... After upgrade Thunderbird should start normally without crashing :D.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-05-04 06:39:20 PDT
Yikes!  Thanks for reporting, AndrzejL.

Starting investigation...
Comment 2 Mike Conley (:mconley) - (needinfo me!) 2012-05-04 09:56:23 PDT
This does not seem to affect debug builds. I was able to get TB to emit symbols without setting --enable-debug, and got the following backtrace:

#0  0xb7fdd424 in __kernel_vsyscall ()
#1  0xb7cfb1ef in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#2  0xb7cfe835 in __GI_abort () at abort.c:91
#3  0xb7f8613d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#4  0xb7f83ed3 in ?? () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#5  0xb7f83f0f in std::terminate() () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#6  0xb7f84b82 in __cxa_pure_virtual () from /usr/lib/i386-linux-gnu/libstdc++.so.6
#7  0xb69cf44c in NS_TableDrivenQI (aThis=<optimized out>, entries=<optimized out>, aIID=..., aInstancePtr=0xbfffd74c) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsISupportsImpl.cpp:49
#8  0xb6183a11 in nsWindowMemoryReporter::QueryInterface (this=0x83bcbd0, aIID=..., aInstancePtr=0xbfffd74c) at /media/Projects/mozilla/thunderbird/mozilla/dom/base/nsWindowMemoryReporter.cpp:54
#9  0xb69cd77f in nsQueryInterfaceWithError::operator() (this=0xbfffd77c, aIID=..., answer=<optimized out>) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsCOMPtr.cpp:64
#10 0xb69cd819 in nsCOMPtr_base::assign_from_qi_with_error (this=0xbfffd78c, qi=..., iid=...) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsCOMPtr.cpp:105
#11 0xb69cf6d7 in nsCOMPtr (qi=..., this=0xbfffd78c) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/build/../glue/nsCOMPtr.h:591
#12 NS_GetWeakReference (aInstancePtr=0x83bcbd4, aErrorPtr=0x0) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsWeakReference.cpp:110
#13 0xb69dfc26 in do_GetWeakReference (error=0x0, aRawPtr=0x83bcbd4) at ../../dist/include/nsIWeakReferenceUtils.h:112
#14 nsObserverList::AddObserver (this=0x83ae8e0, anObserver=0x83bcbd4, ownsWeak=true) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/ds/nsObserverList.cpp:58
#15 0xb618490c in nsWindowMemoryReporter::Init () at /media/Projects/mozilla/thunderbird/mozilla/dom/base/nsWindowMemoryReporter.cpp:72
#16 0xb5d968d3 in nsLayoutStatics::Initialize () at /media/Projects/mozilla/thunderbird/mozilla/layout/build/nsLayoutStatics.cpp:271
#17 0xb5d95597 in Initialize () at /media/Projects/mozilla/thunderbird/mozilla/layout/build/nsLayoutModule.cpp:365
#18 0xb69fb5ee in nsComponentManagerImpl::KnownModule::Load (this=0x81237c0) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:732
#19 0xb69fb70b in nsFactoryEntry::GetFactory (this=0x8123860) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1738
#20 0xb69fcbaa in CreateInstanceByContractID (aResult=0xbfffd958, aIID=..., aDelegate=0x0, aContractID=0x833c680 "@mozilla.org/moz/jsloader;1", this=0x80fef00)
    at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1060
#21 nsComponentManagerImpl::CreateInstanceByContractID (this=0x80fef00, aContractID=<optimized out>, aDelegate=0x0, aIID=..., aResult=0xbfffd958)
    at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1013
#22 0xb69fd736 in GetServiceByContractID (result=0xbfffd9fc, aIID=..., aContractID=0x833c680 "@mozilla.org/moz/jsloader;1", this=0x80fef00) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1466
#23 nsComponentManagerImpl::GetServiceByContractID (this=0x80fef00, aContractID=<optimized out>, aIID=..., result=0xbfffd9fc) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1378
#24 0xb69fda77 in nsGetServiceFromCategory::operator() (this=0xbfffda2c, aIID=..., aInstancePtr=0xbfffd9fc) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:213
#25 0xb69cd929 in nsCOMPtr_base::assign_from_helper (this=0xbfffda48, helper=..., iid=...) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsCOMPtr.cpp:150
#26 0xb69fb45a in operator= (rhs=..., this=0xbfffda48) at ../../dist/include/nsCOMPtr.h:718
#27 nsComponentManagerImpl::LoaderForExtension (this=0x80fef00, aExt=...) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1494
#28 0xb69fb56f in nsComponentManagerImpl::KnownModule::EnsureLoader (this=0x8125ee8) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:709
#29 0xb69fb5b6 in nsComponentManagerImpl::KnownModule::Load (this=0x8125ee8) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:720
#30 0xb69fb70b in nsFactoryEntry::GetFactory (this=0x8242f38) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1738
#31 0xb69fcbaa in CreateInstanceByContractID (aResult=0xbfffdb98, aIID=..., aDelegate=0x0, aContractID=0x8344230 "@mozilla.org/browser-element-api;1", this=0x80fef00)
    at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1060
#32 nsComponentManagerImpl::CreateInstanceByContractID (this=0x80fef00, aContractID=<optimized out>, aDelegate=0x0, aIID=..., aResult=0xbfffdb98)
    at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1013
#33 0xb69fd736 in GetServiceByContractID (result=0xbfffdc1c, aIID=..., aContractID=0x8344230 "@mozilla.org/browser-element-api;1", this=0x80fef00)
    at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1466
#34 nsComponentManagerImpl::GetServiceByContractID (this=0x80fef00, aContractID=<optimized out>, aIID=..., result=0xbfffdc1c) at /media/Projects/mozilla/thunderbird/mozilla/xpcom/components/nsComponentManager.cpp:1378
#35 0xb69ce197 in CallGetService (aContractID=0x8344230 "@mozilla.org/browser-element-api;1", aIID=..., aResult=0xbfffdc1c) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsComponentManagerUtils.cpp:94
#36 0xb69ce43d in nsGetServiceByContractIDWithError::operator() (this=0xbfffdc9c, aIID=..., aInstancePtr=0xbfffdc1c) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsComponentManagerUtils.cpp:288
#37 0xb69cd8f5 in nsCOMPtr_base::assign_from_gs_contractid_with_error (this=0xbfffdcc0, gs=..., iid=...) at /media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/xpcom/build/nsCOMPtr.cpp:141
#38 0xb64ad664 in operator= (rhs=..., this=0xbfffdcc0) at ../../../../dist/include/nsCOMPtr.h:1029
#39 nsAppStartupNotifier::Observe (this=0x830e660, aSubject=0x0, aTopic=0xb6f9be51 "app-startup", someData=0x0) at /media/Projects/mozilla/thunderbird/mozilla/embedding/components/appstartup/src/nsAppStartupNotifier.cpp:100
#40 0xb5c52038 in XREMain::XRE_mainRun (this=0xbfffdf10) at /media/Projects/mozilla/thunderbird/mozilla/toolkit/xre/nsAppRunner.cpp:3606
#41 0xb5c54f5d in XREMain::XRE_main (this=0xbfffdf10, argc=1, argv=0xbffff1b4, aAppData=0x80697d0) at /media/Projects/mozilla/thunderbird/mozilla/toolkit/xre/nsAppRunner.cpp:3857
#42 0xb5c551a2 in XRE_main (argc=1, argv=0xbffff1b4, aAppData=0x80697d0) at /media/Projects/mozilla/thunderbird/mozilla/toolkit/xre/nsAppRunner.cpp:3933
#43 0x08049579 in do_main (argv=0xbffff1b4, argc=1, exePath=0xbfffe0fc "/media/Projects/mozilla/objnodbg-thunderbird-patches/mozilla/dist/bin/") at /media/Projects/mozilla/thunderbird/mail/app/nsMailApp.cpp:144
#44 main (argc=1, argv=0xbffff1b4) at /media/Projects/mozilla/thunderbird/mail/app/nsMailApp.cpp:233
Comment 3 Mark Banner (:standard8) 2012-05-04 11:08:11 PDT
We've found the cause for this as bug 736564 - we needed to port that across to our build system.

I've now done this as a bustage fix:

http://hg.mozilla.org/comm-central/rev/bb7825549f3d

I'll be triggering new Linux nightlies to get this fixed there.
Comment 4 Mike Hommey [:glandium] 2012-05-04 11:17:24 PDT
Note you'll have to change this again when the second part of bug 736564, currently in inbound, is merged on m-c.
Comment 5 AndrzejL 2012-05-04 14:38:40 PDT
I had to redownload and unpack the tar.bz2 file (to be expected when testing) but the issue is gone.

Thanks guys! You are awesome :).

Andrzej
Comment 6 AndrzejL 2012-05-04 14:41:12 PDT
(In reply to Mike Conley (:mconley) from comment #1)
> Yikes!  Thanks for reporting, AndrzejL.
> 
> Starting investigation...

All pleasure on my side mate. I love Mozilla products and testing and reporting is the only way I can repay You for great work.

Thanks again.

Andrzej
Comment 7 Philip Chee 2012-05-04 22:39:24 PDT
*** Bug 752140 has been marked as a duplicate of this bug. ***
Comment 8 Dominik 2012-07-24 04:44:24 PDT
Hello,

I am using/embedding XulRunner 14.0.1 and I encounter the same problem (13.0 did work).

I can see that in the current XulRunner 15 Beta SDK there is a libmemory.a/libmozglue.a file included, but none in the 14.0.1 SDK.

Do I have to build my own libraries from source for that case?

Regards,
Dominik
Comment 9 AndrzejL 2012-07-30 05:51:23 PDT
Hi Dominik.

I have not compiled anything to get my Thunderbird Daily to run.

I have kept the installation of the distro / repository version to make sure that I have all the necessary libraries and then I did this: http://sparewotw.wordpress.com/2012/07/30/testing-mozilla-thunderbird-central-daily-17-safely-on-pclinuxos-2012-x/

Hope this helps.

Regards.

Andrzej
Comment 10 Tom Hindle 2012-07-30 13:27:49 PDT
@Dominik,

I think I had the same problem as you, while embedding libxul using firefox 14:

It was caused by a weak ref to jemalloc_stats.

For more details see:
https://bitbucket.org/geckofx/geckofx-14.0/issue/3/crash-on-geckowebbrowser-onhandlecreated

Note You need to log in before you can comment on or make changes to this bug.