If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Reinstalling an Application while its running removes desktop shortcuts and start menu references

RESOLVED FIXED

Status

Firefox Graveyard
Web Apps
P2
normal
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: jsmith, Unassigned)

Tracking

15 Branch
x86_64
Windows 7

Details

(Reporter)

Description

6 years ago
Steps:

1. Install an application (https://apps.mozillalabs.com/appdir/)
2. Launch an application
3. Reinstall that same application while the app is running

Expected:

I would expect an error to be thrown (which an error is thrown, although its a bit ambiguous on what the error message means) indicating that the app cannot be installed, as the app is installed and running.

Actual:

An error is thrown (even if its a bit ambiguous - "App installed not allowed" on marketplace), but the desktop shortcut and start menu items disappear as a result. The executable for the app still remains in %APPDATA%. This is incorrect - We should fail gracefully without removing desktop shortcuts and start menu items.

Additional Notes:

The correct behavior as a result of this bug generally needs to make sure to handle this case gracefully, not end up in a case where there some app data left behind.
(Reporter)

Updated

5 years ago
Blocks: 731054
(Reporter)

Comment 1

5 years ago
Open question - Marketplace reinstall flow?
Priority: -- → P2
(Reporter)

Updated

5 years ago
Target Milestone: --- → Firefox 15
(Reporter)

Updated

5 years ago
No longer blocks: 731054
Target Milestone: Firefox 15 → ---
Depends on: 765380
(Reporter)

Updated

5 years ago
QA Contact: jsmith
(Reporter)

Updated

5 years ago
status-firefox16: --- → wontfix
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 765380
Resolution: --- → DUPLICATE
Duplicate of bug: 765380
This was fixed by bug 749826.
Depends on: 749826
Resolution: DUPLICATE → FIXED
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.