Ctrl-W doesn't close popup windows

VERIFIED WORKSFORME

Status

()

P2
normal
VERIFIED WORKSFORME
18 years ago
16 years ago

People

(Reporter: caseyperkins, Assigned: bugs)

Tracking

Trunk
mozilla1.1alpha
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [focus], URL)

(Reporter)

Description

18 years ago
Reproducible: Always
Steps to reproduce:
1) Go to a web site that uses Javascript to launch a popup window, such as
www.nationalreview.com or www.espn.com.
2) After the popup window appears and is the active window, press Ctrl-W.
Expected result: Window should close.
Actual result: Nothing.

I am filing this bug in response to instructions by Matthew Thomas
(mpt@mailandnews.com), which he gave while we were discussing bug 69766, which
is a similar, but not identical bug.

Comment 1

18 years ago
reassigning to XPApps
Assignee: asa → pchen
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps
Ever confirmed: true
QA Contact: doronr → sairuh
if you click inside the popup dialog [to bring it into focus], will ctrl+W
dismiss it? if so, that's a known focus bug, afaik.  jrgm, d'you remember the
bug number[s] for the "need to click to bring focus before keyboard shortcuts
will work" issue? i'll go search, too...
might be related to bug 58853, but that pertains to dialogs --not sure if it
also covers js popups.

saari/aaronl/jesse, is there a toolkit bug for this?
Assignee: pchen → aaronl
Component: XP Apps → Keyboard Navigation

Updated

18 years ago
Priority: -- → P2
Target Milestone: --- → mozilla1.1

Comment 4

18 years ago
Okay, this works for me - Accel+W closes to popup as long as I wait until the 
popup is finished loading. OTOH, Alt+F4 works even if it hasn't finished 
loading.

Can someone else verify that this is correct?

If so, we can look to see where Alt+F4 and Accel+W are coded, and move the 
coding for Accel+W to be the same as Alt+F4, right?
(Reporter)

Comment 5

18 years ago
No, Accel-W never works for me to close a popup window; not when the window
first pops up, not after it has finished loading, nor after I click on the
window and try to close it with the shortcut.

Updated

18 years ago
Whiteboard: [focus]

Comment 6

18 years ago
Can someone tell me if Ctrl+W is supposed to act exactly the same as Alt+F4?

Comment 7

18 years ago
afaik ctrl-w should only affect navigator windows, not alerts, not dialogs, 
(not sure about non navigator creatures...)

As for the intended question (should ctrl-w and alt-f4 behave the same for 
navigator windows) i'm not sure, if there happens to be a dom reason for them 
to be different then...

Comment 8

18 years ago
I think Ctrl+W is supposed to close all of those windows.
However, I think it sometimes intended to delete a word (in UNIX). That's why it
can't work exactly the same.

Reassigning to Ben, as a chrome issue, who can find the right person for it.
Assignee: aaronl → ben

Comment 9

17 years ago
seeing this bug in mac build id: 2001092608

Comment 10

17 years ago
dupe of bug 103758 ??

Comment 11

17 years ago
This works for me in a new nightly. I don't even have to click in the popup
first to make it work, but even if you do, that's a separate (filed) bug. That
said, can anyone still not close popup windows with ctrl+w even after clicking
within the window?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.