Tiling-related glitching on tbpl

RESOLVED FIXED in Firefox 18

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: kats, Assigned: BenWa)

Tracking

unspecified
Firefox 18
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

Attachments

(2 attachments)

Posted image Screenshot
STR:

1. Load tbpl.mozilla.org
2. Try panning/pinching

Expected results:
page draws normally

Actual results:
occasionally the page background goes black, sometimes the black area is obviously tiled rects. it's a little hard to explain but not that hard to reproduce. See attached screenshot.

It's a pretty severe issue and should be blocking.

Tested on both the Galaxy Nexus and Galaxy Tab with a build from 9ebf3dc839c5 (recent m-c)
Can reproduce, no ideas immediately spring to mind of what this could be.
Assignee

Comment 2

7 years ago
Probably my bug. Most likely a problem with either opaque surface and/or clearing the surface.
Assignee: nobody → bgirard
blocking-fennec1.0: ? → -
We'll approve things for fixing the test though

Updated

7 years ago
Duplicate of this bug: 784707
Assignee

Updated

7 years ago
Duplicate of this bug: 786949
Attachment #656983 - Flags: review?(joe) → review+
Assignee

Comment 7

7 years ago
Comment on attachment 656983 [details] [diff] [review]
Don't reuse an old tile if the format changed

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 739679
User impact if declined: Users will see black tiles on some more complex pages with transparent layers (ex: TBPL, google news reader)
Testing completed (on m-c, etc.): on inbound, soon on m-c
Risk to taking this patch (and alternatives if risky): Fennec only, low one line change.
String or UUID changes made by this patch: one
Attachment #656983 - Flags: approval-mozilla-beta?
Attachment #656983 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d04edff1ae41
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Comment on attachment 656983 [details] [diff] [review]
Don't reuse an old tile if the format changed

[Triage Comment]
Low risk mobile-only fix in support of web compatibility. Approving for Aurora 17 and Beta 16.
Attachment #656983 - Flags: approval-mozilla-beta?
Attachment #656983 - Flags: approval-mozilla-beta+
Attachment #656983 - Flags: approval-mozilla-aurora?
Attachment #656983 - Flags: approval-mozilla-aurora+
Depends on: 787416
Assignee

Comment 11

7 years ago
This patch isn't going to get uplifted because of the regressions.

Comment 12

7 years ago
Yeah, I believe this patch unintentionally caused issues here:
https://bugzilla.mozilla.org/show_bug.cgi?id=787732
Am I correct? Just trying to follow what's going on here, it's quite fast-paced. That's what you mean by regressions, right?
Assignee

Comment 13

7 years ago
Yes, there's a fix underway.
Attachment #656983 - Flags: approval-mozilla-beta-
Attachment #656983 - Flags: approval-mozilla-beta+
Attachment #656983 - Flags: approval-mozilla-aurora-
Attachment #656983 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.