navigator not defined in web console

RESOLVED DUPLICATE of bug 751077

Status

RESOLVED DUPLICATE of bug 751077
7 years ago
4 months ago

People

(Reporter: ianbicking, Unassigned)

Tracking

({regression})

15 Branch
x86
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
When I open the web console and use "navigator" it is undefined.

Navigator and its attributes still show up in completion.
Could be related to Bug 726949 ?
(Reporter)

Comment 2

7 years ago
window.navigator works for me.  Is there a build of Nightly that would have this fix in? I'm on 2012-05-04.
(In reply to Ian Bicking (:ianb) from comment #2)
> window.navigator works for me.  Is there a build of Nightly that would have
> this fix in? I'm on 2012-05-04.

This is a regression from Firefox 12. The fix from bug 726949 is already in nightly, but doesn't seem to fix this. bz, bholley: what is different about this case compared to that bug? Do we need regressionwindow-wanted?
Keywords: regression
> bz, bholley: what is different about this case compared to that bug?

It's an own expando property, not an IDL property.  Patch is waiting for bholley to review.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 751077

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.