The default bug view has changed. See this FAQ.

Failure during event creation [Exception 'TypeError: aItem.calendar.isInvitation is not a function' in calProviderUtils.jsm]

RESOLVED FIXED in 1.7

Status

Calendar
General
--
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

({regression})

Lightning 1.7
regression

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Lightning 1.7a1 (BuildID: 20120502041524) with
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Thunderbird/15.0a1

Steps to reproduce:
1. create a new Thunderbird profile
2. install Lightning extension
3. create event in the default Home calendar
4. check console

Result:
Error: [Exception... "'TypeError: aItem.calendar.isInvitation is not a function' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"  location: "JS frame :: resource://calendar/modules/calProviderUtils.jsm :: cPB_notifyOperationComplete :: line 694"  data: no]
Stefan, any idea of the regression range on this?
(Reporter)

Comment 2

5 years ago
Regressed by a change in Thunderbird or Toolkit but not Lightning.

Works: Thunderbird 15.0a1 (20120503134801)
Fails: Thunderbird 15.0a1 (20120504031629)

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c045085c0436&tochange=e1a40027dc7e

https://hg.mozilla.org/comm-central/pushloghtml?fromchange=70ea52e442be&tochange=c97558cdadef
(Assignee)

Updated

5 years ago
Severity: normal → critical
(Assignee)

Updated

5 years ago
Severity: critical → blocker
OS: Windows 7 → All
Hardware: x86_64 → All
(Assignee)

Comment 3

5 years ago
Created attachment 624989 [details] [diff] [review]
Fix - v1

I can't say for sure why this patch fixes it, but it does. The original culprit was in calItipUtils, where isInvitation and getInvitedAttendees is checked just like the helper function in calUtils. But, for some reason the helper function in calUtils works!

I've also added calICalendar and calISchedulingSupport to the caldav provider's getInterfaces, in case thats part of the problem.

Just from a gut feeling, I think it might have to do with something in the wake of CPG, that if a QI is done in one compartment, then its not done so for the other one. Since calInstanceOf is also in calUtils.jsm, the patch works.

We might have to ask some xpconnect gurus on that or just hope nothing else breaks, or get rid of calInstanceOf some time.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #624989 - Flags: review?(matthew.mecca)
Comment on attachment 624989 [details] [diff] [review]
Fix - v1

Looks good. r=mmecca
Attachment #624989 - Flags: review?(matthew.mecca) → review+
(Assignee)

Comment 5

5 years ago
Pushed to comm-central changeset 4a12eafd0b08
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.7
You need to log in before you can comment on or make changes to this bug.